summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-08-16 00:38:49 -0400
committerMark H Weaver <mhw@netris.org>2016-08-17 14:16:10 -0400
commitcb50d0c278e68048d4bd1c30441801ff7e454304 (patch)
tree30dadecedfb1253c8294b4f7187ecb9a587c8f36 /gnu/packages/video.scm
parentc437922a0d85a4749f3d2f64c8f061cfb0954043 (diff)
downloadguix-cb50d0c278e68048d4bd1c30441801ff7e454304.tar.gz
gnu: libx264: Fix build on MIPS.
* gnu/packages/video.scm (libx264)[arguments]: On MIPS, add
"--disable-asm" to #:configure-flags.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 98b7c41d9f..bc6415ec74 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -222,7 +222,18 @@ television and DVD.  It is also known as AC-3.")
                            ;; package to avoid a circular dependency (the x264
                            ;; program depends on ffmpeg and ffmpeg depends on
                            ;; libx264).
-                           "--disable-cli")))
+                           "--disable-cli"
+
+                           ;; On MIPS, we must pass "--disable-asm" or else
+                           ;; configure fails after printing: "You specified a
+                           ;; pre-MSA CPU in your CFLAGS. If you really want
+                           ;; to run on such a CPU, configure with
+                           ;; --disable-asm."
+                           ,@(if (string-prefix? "mips"
+                                                 (or (%current-target-system)
+                                                     (%current-system)))
+                                 '("--disable-asm")
+                                 '()))))
     (home-page "http://www.videolan.org/developers/x264.html")
     (synopsis "H.264 video coding library")
     (description "libx264 is an advanced encoding library for creating