summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-10-26 19:50:17 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-27 00:01:53 +0200
commitb1c01503dfcb915c39af4a45716ebafafb806549 (patch)
tree6af8cdcb41d8ebaefd81efe0348a261909ad2524 /gnu/packages/video.scm
parent6b88912eb6c414467234678c347990181dbf848b (diff)
downloadguix-b1c01503dfcb915c39af4a45716ebafafb806549.tar.gz
gnu: Add ffmpeg@3.3 and use it on packages that fail with 3.4.
* gnu/packages/gstreamer.scm (gst-libav)[inputs]: Change ffmpeg to ffmpeg-3.3.
* gnu/packages/messaging.scm (qtox)[inputs]: Change ffmpeg to ffmpeg-3.3.
* gnu/packages/video.scm (ffmpeg-3.3): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d73e21a31b..5596c48397 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -751,6 +751,18 @@ convert and stream audio and video.  It includes the libavcodec
 audio/video codec library.")
     (license license:gpl2+)))
 
+(define-public ffmpeg-3.3
+  (package
+    (inherit ffmpeg)
+    (version "3.3.4")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
+                                 version ".tar.xz"))
+             (sha256
+              (base32
+               "0mx9dvad3lkyhvsrblf280x2bz6dxajya1ylnspbdzldj0dpxfcq"))))))
+
 (define-public ffmpeg-2.8
   (package
     (inherit ffmpeg)