summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 16:48:20 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 20:08:24 +0200
commitafdc16d9041fde77913b6e84679dc581c54df2d6 (patch)
tree47e317d81abee3e10a68f4d7ba54c81775039884 /gnu/packages/video.scm
parentcd03e2cb2f5759e158392b9fe67d805b7b41c574 (diff)
downloadguix-afdc16d9041fde77913b6e84679dc581c54df2d6.tar.gz
gnu: x265: Update to 3.4.
* gnu/packages/patches/x265-arm-flags.patch: Update patch.
* gnu/packages/video.scm (x265): Update to 3.4.
[arguments]: Remove obsolete substitution.  Disable the newly-added assembly
optimizations on AArch64, as they are not implemented for all targets we build.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c5e4993091..9c88066c91 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -611,7 +611,7 @@ available.")
 (define-public x265
   (package
     (name "x265")
-    (version "3.3")
+    (version "3.4")
     (outputs '("out" "static"))
     (source
       (origin
@@ -621,7 +621,7 @@ available.")
                    (string-append "https://download.videolan.org/videolan/x265/"
                                   "x265_" version ".tar.gz")))
         (sha256
-         (base32 "170b61cgpcs5n35qps0p40dqs1q81vkgagzbs4zv7pzls6718vpj"))
+         (base32 "0wl62hfsdqpf3r3z3s6l9bz7pdb1rcik5ll00b3yaadplqipy162"))
         (patches (search-patches "x265-arm-flags.patch"))
         (modules '((guix build utils)))
         (snippet '(begin
@@ -638,8 +638,7 @@ available.")
        #:configure-flags
          ;; Ensure position independent code for everyone.
          (list "-DENABLE_PIC=TRUE"
-               ,@(if (string-prefix? "armhf" (or (%current-system)
-                                                 (%current-target-system)))
+               ,@(if (target-arm?)
                      '("-DENABLE_ASSEMBLY=OFF")
                      '())
                (string-append "-DCMAKE_INSTALL_PREFIX="
@@ -650,9 +649,6 @@ available.")
            (lambda _
              (delete-file-recursively "build")
              (chdir "source")
-             ;; recognize armv8 in 32-bit mode as ARM
-             (substitute* "CMakeLists.txt"
-              (("armv6l") "armv8l"))
              #t))
          (add-before 'configure 'build-12-bit
            (lambda* (#:key (configure-flags '()) #:allow-other-keys)