summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTimo Eisenmann <eisenmann@fn.de>2019-02-25 19:38:54 +0100
committerLeo Famulari <leo@famulari.name>2019-02-25 21:33:45 -0500
commit04b6e9c5dffb0830338dda39d90cf7b2d165b3fc (patch)
treeb7914acc2c8b372562c83742e747477143cc173a /gnu/packages/video.scm
parent6dacaa70a0874662cbdabfc6df987cd5a09a518c (diff)
downloadguix-04b6e9c5dffb0830338dda39d90cf7b2d165b3fc.tar.gz
gnu: twitchy: Update to 3.4.
* gnu/packages/video.scm: (twitchy): Update to 3.4.
[arguments]: Add phase 'patch-paths' to substitute in the absolute path to
'streamlink'.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b0c875befe..52f151bd78 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -32,6 +32,7 @@
 ;;; Copyright © 2018 Mark Meyer <mark@ofosos.org>
 ;;; Copyright © 2018 Gábor Boskovit <boskovits@gmail.com>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Timo Eisenmann <eisenmann@fn.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1999,10 +2000,10 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
   (deprecated-package "livestreamer" streamlink))
 
 (define-public twitchy
-  (let ((commit "0c0f925b9c7ff2aed4a3b0046561cb794143c398")) ;Fixes tests.
+  (let ((commit "9beb36d80b16662414129693e74fa3a2fd97554e")) ; 3.4 has no tag
     (package
       (name "twitchy")
-      (version (git-version "3.2" "1" commit))
+      (version (git-version "3.4" "1" commit))
       (source
        (origin
          (method git-fetch)
@@ -2012,11 +2013,18 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
          (file-name (git-file-name name version))
          (sha256
           (base32
-           "02aizvsr744sh8bdqvwwsmp2qpczlzn8fy76h5dyd3517n9nlcz9"))))
+           "0di03h1j9ipp2bbnxxlxz07v87icyg2hmnsr4s7184z5ql8kpzr7"))))
       (build-system python-build-system)
       (arguments
        '(#:phases
          (modify-phases %standard-phases
+           (add-after 'unpack 'patch-paths
+             (lambda* (#:key inputs #:allow-other-keys)
+               (substitute* "twitchy/twitchy_play.py"
+                 (("\"streamlink ")
+                  (string-append "\"" (assoc-ref inputs "streamlink")
+                                 "/bin/streamlink ")))
+               #t))
            (add-before 'check 'check-setup
              (lambda _
                (setenv "HOME" (getcwd)) ;Needs to write to ‘$HOME’.