summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2017-07-10 23:25:26 +0800
committerArun Isaac <arunisaac@systemreboot.net>2017-07-13 02:01:47 +0530
commit63cd4d53fbe8775e59e463b7d6e5579c4bdfb54f (patch)
tree12b99859f1d34e8005ba9ea61d6df7dd04614bdf /gnu/packages/video.scm
parentd89ce52096982d2b5ff3f81f9dc0c8316590fe41 (diff)
downloadguix-63cd4d53fbe8775e59e463b7d6e5579c4bdfb54f.tar.gz
gnu: Add simplescreenrecorder.
* gnu/packages/video.scm (simplescreenrecorder): New variable.

Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm40
1 files changed, 39 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 5338d375ee..2a1b070d87 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2015 Andy Patterson <ajpatter@uwaterloo.ca>
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015, 2016 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2015, 2016, 2017 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
 ;;; Copyright © 2016 Dmitry Nikolaev <cameltheman@gmail.com>
@@ -1888,6 +1888,44 @@ your graphical desktop and encodes it as a video.  This is a useful tool for
 making @dfn{screencasts}.")
     (license license:gpl2+)))
 
+(define-public simplescreenrecorder
+  (package
+    (name "simplescreenrecorder")
+    (version "0.3.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/MaartenBaert/ssr/archive/"
+                           version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0v8w35n8w772s08w7k0icynqdsdakbrcanbgx6j847bfqfsg21gg"))))
+    (build-system gnu-build-system)
+    ;; Although libx11, libxfixes, libxext are listed as build dependencies in
+    ;; README.md, the program builds and functions properly without them.
+    ;; As a result, they are omitted. Please add them back if problems appear.
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("ffmpeg" ,ffmpeg)
+       ("glu" ,glu)
+       ("jack" ,jack-1)
+       ("libxi" ,libxi)
+       ("pulseaudio" ,pulseaudio)
+       ("qt" ,qt-4))) ; README.md: using Qt 5 causes some stability issues
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    ;; Using HTTPS causes part of the page to be displayed improperly.
+    (home-page "http://www.maartenbaert.be/simplescreenrecorder/")
+    (synopsis "Screen recorder")
+    (description "SimpleScreenRecorder is an easy to use screen recorder with
+a graphical user interface.  It supports recording the entire screen, or a
+part of it, and allows encoding in many different codecs and file formats.
+Other features include a live preview and live streaming.")
+    (license (list license:gpl3+ ; most files
+                   license:zlib ; glinject/elfhacks.*
+                   license:isc ; glinject/*
+                   license:x11)))) ; build-aux/install-sh
+
 (define-public libsmpeg
   (package
     (name "libsmpeg")