summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-06 17:07:55 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-09 22:57:44 +0100
commitf1044010951d5b48e92b6977980666c013525084 (patch)
treeac6c04fe30efa0e492a11c32b74438ce13d68835 /gnu/packages/video.scm
parenta6f710ec4e4afdecd28c5f2c395847162a9b2438 (diff)
downloadguix-f1044010951d5b48e92b6977980666c013525084.tar.gz
gnu: Add libdvdnav-4.
* gnu/packages/video.scm (libdvdnav-4): New variable.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 670e731259..ba6a48fb58 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -31,6 +31,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages audio)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages avahi)
   #:use-module (gnu packages cdrom)
   #:use-module (gnu packages compression)
@@ -594,6 +595,32 @@ DVD virtual machine and internal playback states are completely
 encapsulated.")
     (license gpl2+)))
 
+(define-public libdvdnav-4
+  (package
+    (inherit libdvdnav)
+    (version "4.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append
+                "http://download.videolan.org/videolan/libdvdnav/libdvdnav-"
+                version ".tar.xz"))
+              (sha256
+               (base32
+                "0wi3gy408c8xj0ism0hckv5jbfh3lg4pmgxv87gbch9jrhp2gjkz"))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
+    (arguments
+     '(#:phases
+       (alist-cons-after
+        'unpack 'autoreconf
+        (lambda _
+          (zero? (system* "autoreconf" "-vif")))
+        %standard-phases)))))
+
 (define-public libdvdcss
   (package
     (name "libdvdcss")