summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-18 12:08:31 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-18 12:08:31 +0200
commit4ef2721b52c4929aac15db4f8b39702cd37955a1 (patch)
treef8620fb309484a131ec2681e7530304a55382865 /gnu/packages/video.scm
parentb4dff935500abc5aceb3fc0e13fb7cabb5f756c0 (diff)
downloadguix-4ef2721b52c4929aac15db4f8b39702cd37955a1.tar.gz
gnu: vlc: Do not capture the build time.
* gnu/packages/video.scm (vlc)[source]: Add 'snippet'.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7877961901..0e80dd459c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -567,7 +567,14 @@ audio/video codec library.")
                    version "/vlc-" version ".tar.xz"))
              (sha256
               (base32
-               "1jqzrzrpw6932lbkf863xk8cfmn4z2ngbxz7w8ggmh4f6xz9sgal"))))
+               "1jqzrzrpw6932lbkf863xk8cfmn4z2ngbxz7w8ggmh4f6xz9sgal"))
+             (modules '((guix build utils)))
+             (snippet
+              ;; There are two occurrences where __DATE__ and __TIME__ are
+              ;; used to capture the build time and show it to the user.
+              '(substitute* (find-files "." "help\\.c(pp)?$")
+                 (("__DATE__") "\"2016\"")
+                 (("__TIME__") "\"00:00\"")))))
     (build-system gnu-build-system)
     (native-inputs
      `(("git" ,git) ; needed for a test