summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-01 22:15:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-02 09:21:47 +0300
commite7228f0cfaf7b09f895111886a4df6aa53812ecd (patch)
tree576ae46863efde16b31cb5b21f4ad2e63f188387 /gnu/packages/video.scm
parent5020a263921c02c957d880867f56d1287e8cb0f8 (diff)
downloadguix-e7228f0cfaf7b09f895111886a4df6aa53812ecd.tar.gz
gnu: openshot: Enable tests.
* gnu/packages/video.scm (openshot)[arguments]: Add custom 'check phase.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index fcd9c9aca8..c62e651612 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3681,14 +3681,17 @@ API.  It includes bindings for Python, Ruby, and other languages.")
        ("python-requests" ,python-requests)
        ("qtsvg" ,qtsvg)))
     (arguments
-     `(#:tests? #f                      ;no tests
-       #:modules ((guix build python-build-system)
+     `(#:modules ((guix build python-build-system)
                   (guix build qt-utils)
                   (guix build utils))
        #:imported-modules (,@%python-build-system-modules
                             (guix build qt-utils))
        #:phases (modify-phases %standard-phases
                   (delete 'build)       ;install phase does all the work
+                  (replace 'check
+                    (lambda _
+                      (setenv "QT_QPA_PLATFORM" "offscreen")
+                      (invoke "python" "src/tests/query_tests.py")))
                   (add-after 'unpack 'patch-font-location
                     (lambda* (#:key inputs #:allow-other-keys)
                       (let ((font (assoc-ref inputs "font-ubuntu")))