summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-07-26 15:24:20 +0200
committerAndreas Enge <andreas@enge.fr>2015-07-26 15:24:20 +0200
commita060ca32011d6224bbc2ce70f73314a9ab51c188 (patch)
tree02a87c172683c65fe83bb3d81c2f2600e5b4bc7e /gnu/packages/video.scm
parent2520c84a6f21f0aaf8d27296a00edcf4899d5f48 (diff)
downloadguix-a060ca32011d6224bbc2ce70f73314a9ab51c188.tar.gz
gnu: avidemux: Install libraries to lib.
* gnu/packages/video.scm (avidemux)[source]: Add patch to install to lib
  directory instead of lib64 or lib32 depending on the architecture.
  [arguments]: Use the lib instead of the lib64 directory for flags in the
  build phase, so that these flags should now also work on i686.
* gnu/packages/patches/avidemux-install-to-lib.patch: New file.
* gnu-system.am (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6ebd7787e1..c57c6c6700 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1090,7 +1090,8 @@ for use with HTML5 video.")
                    version ".tar.gz"))
              (sha256
               (base32
-               "10p60wjkzf1bxqcb6i7bx4hbqy3vqg598p3l9lc4v2c9b8iqr682"))))
+               "10p60wjkzf1bxqcb6i7bx4hbqy3vqg598p3l9lc4v2c9b8iqr682"))
+             (patches (map search-patch '("avidemux-install-to-lib.patch")))))
     (build-system cmake-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -1145,7 +1146,7 @@ for use with HTML5 video.")
             (lambda* (#:key inputs outputs #:allow-other-keys)
               (let*
                 ((out (assoc-ref outputs "out"))
-                 (lib (string-append out "/lib64"))
+                 (lib (string-append out "/lib"))
                  (top (getcwd))
                  (sdl (assoc-ref inputs "sdl"))
                  (build_component