summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-05 19:54:25 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-09 22:57:45 +0100
commit7124119203958aff1ff45e3340e1c76c8cd126c6 (patch)
tree40ff744b0afbe6efb9b085dfd9fe7afc06662aba /gnu/packages/video.scm
parentcc6c01706600326f90b01f0a3a789bf463cef650 (diff)
downloadguix-7124119203958aff1ff45e3340e1c76c8cd126c6.tar.gz
gnu: ffmpeg: Add more optional inputs.
* gnu/packages/video.scm (ffmpeg): Add inputs ladspa, openal, pulseaudio.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 5404f9df9c..3b7161b884 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -175,6 +175,7 @@ SMPTE 314M.")
      `(("fontconfig" ,fontconfig)
        ("freetype" ,freetype)
        ("opus" ,opus)
+       ("ladspa" ,ladspa)
        ("lame" ,lame)
        ("libbluray" ,libbluray)
        ("libcaca" ,libcaca)
@@ -183,7 +184,9 @@ SMPTE 314M.")
        ("libtheora" ,libtheora)
        ("libvorbis" ,libvorbis)
        ("libvpx" ,libvpx)
+       ("openal" ,openal)
        ("patchelf" ,patchelf)
+       ("pulseaudio" ,pulseaudio)
        ("soxr" ,soxr)
        ("speex" ,speex)
        ("twolame" ,twolame)
@@ -220,7 +223,6 @@ SMPTE 314M.")
 ;; possible additional inputs:
 ;;   --enable-avisynth        enable reading of AviSynth script files [no]
 ;;   --enable-frei0r          enable frei0r video filtering
-;;   --enable-ladspa          enable LADSPA audio filtering
 ;;   --enable-libaacplus      enable AAC+ encoding via libaacplus [no]
 ;;   --enable-libass          enable libass subtitles rendering [no]
 ;;   --enable-libcelt         enable CELT decoding via libcelt [no]
@@ -240,7 +242,6 @@ SMPTE 314M.")
 ;;   --enable-libopencore-amrwb enable AMR-WB decoding via libopencore-amrwb [no]
 ;;   --enable-libopencv       enable video filtering via libopencv [no]
 ;;   --enable-libopenjpeg     enable JPEG 2000 de/encoding via OpenJPEG [no]
-;;   --enable-libpulse        enable Pulseaudio input via libpulse [no]
 ;;   --enable-librtmp         enable RTMP[E] support via librtmp [no]
 ;;   --enable-libschroedinger enable Dirac de/encoding via libschroedinger [no]
 ;;   --enable-libshine        enable fixed-point MP3 encoding via libshine [no]
@@ -257,7 +258,6 @@ SMPTE 314M.")
 ;;   --enable-libxavs         enable AVS encoding via xavs [no]
 ;;   --enable-libzmq          enable message passing via libzmq [no]
 ;;   --enable-libzvbi         enable teletext support via libzvbi [no]
-;;   --enable-openal          enable OpenAL 1.1 capture support [no]
 ;;   --enable-opencl          enable OpenCL code
 ;;   --enable-x11grab         enable X11 grabbing [no]
               (zero? (system*
@@ -267,12 +267,14 @@ SMPTE 314M.")
                       "--enable-shared"
                       "--enable-fontconfig"
                       ;; "--enable-gnutls" ; causes test failures
+                      "--enable-ladspa"
                       "--enable-libbluray"
                       "--enable-libcaca"
                       "--enable-libcdio"
                       "--enable-libfreetype"
                       "--enable-libmp3lame"
                       "--enable-libopus"
+                      "--enable-libpulse"
                       "--enable-libquvi"
                       "--enable-libsoxr"
                       "--enable-libspeex"
@@ -281,6 +283,7 @@ SMPTE 314M.")
                       "--enable-libvorbis"
                       "--enable-libvpx"
                       "--enable-libxvid"
+                      "--enable-openal"
 
                       "--enable-runtime-cpudetect"