summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-04-04 13:18:40 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-04-05 12:42:36 -0400
commite16fde1447840ffb1cafd505b10c4296da4d44e3 (patch)
tree197bee4d066f9c161ffe552c11aa40af1ea2c26e /gnu/packages/video.scm
parent0234ca06ceccb6d5ad7c13b98e7998b371bc6c08 (diff)
downloadguix-e16fde1447840ffb1cafd505b10c4296da4d44e3.tar.gz
gnu: Add livestreamer.
* gnu/packages/video.scm (livestreamer): New variable.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 58263f0826..8ded42ce96 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1300,3 +1300,30 @@ codec library.  It uses ASP features such as b-frames, global and quarter
 pixel motion compensation, lumi masking, trellis quantization, and H.263, MPEG
 and custom quantization matrices.")
     (license license:gpl2+)))
+
+(define-public livestreamer
+  (package
+    (name "livestreamer")
+    (version "1.12.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/chrippa/livestreamer/archive/v"
+                    version ".tar.gz"))
+              (file-name (string-append "livestreamer-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1dhgk8v8q1h3km4g5jc0cmjsxdaa2d456fvdb2wk7hmxmmwbqm9j"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:tests? #f)) ; tests rely on external web servers
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (propagated-inputs
+     `(("python-requests" ,python-requests)
+       ("python-singledispatch" ,python-singledispatch)))
+    (synopsis "Internet video stream viewer")
+    (description "Livestreamer is a command-line utility that extracts streams
+from various services and pipes them into a video playing application.")
+    (home-page "http://livestreamer.io/")
+    (license license:bsd-2)))