summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-01 10:17:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-01 10:17:47 +0300
commit2a844af991a301052045bdc5f3bcc0f779185079 (patch)
tree084e17cc5463e6ec9f694e5e750171c4854f9251 /gnu/packages/video.scm
parentb51a37b1164824b1a510c079fb1a50747f27d72c (diff)
downloadguix-2a844af991a301052045bdc5f3bcc0f779185079.tar.gz
gnu: mpv-mpris: Switch to copy-build-system.
* gnu/packages/video.scm (mpv-mpris)[build-system]: Switch to
copy-build-system.
[arguments]: Add custom 'build phase before 'install phase.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 5a6a061459..03796fd770 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -65,6 +65,7 @@
   #:use-module (guix git-download)
   #:use-module (guix svn-download)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system meson)
@@ -1549,18 +1550,16 @@ projects while introducing many more.")
         (sha256
          (base32
           "1fr3jvja8s2gdpx8qyk9r17977flms3qpm8zci62nd9r5wjdvr5i"))))
-    (build-system gnu-build-system)
+    (build-system copy-build-system)
     (arguments
-     '(#:tests? #f ; no tests
-       #:make-flags '("CC=gcc")
+     '(#:install-plan
+       '(("mpris.so" "lib/"))
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure) ; no configure script
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (install-file "mpris.so" (string-append out "/lib")))
-             #t)))))
+         (add-before 'install 'build
+           (lambda _
+             (setenv "CC" (which "gcc"))
+             (invoke "make"))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs