summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-04-01 17:10:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-04-01 17:14:10 +0200
commit3f3daa1cc1c8be4c46da28c9268dbdf9c80f950a (patch)
tree05993db7a71ddd5d504add0577950f80a9904ae6 /gnu/packages/video.scm
parentc26fd5648c2a24dbd71f4c0851f8b5eced75e0f1 (diff)
downloadguix-3f3daa1cc1c8be4c46da28c9268dbdf9c80f950a.tar.gz
gnu: openshot: Fix ‘color shift.png’ file name.
* gnu/packages/video.scm (openshot)[source]: Rename it to
‘colorshift.png’ in the snippet.

Reported by <znavko@disroot.org>.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 03796fd770..88e7aeadde 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3668,6 +3668,10 @@ API.  It includes bindings for Python, Ruby, and other languages.")
        (modules '((guix build utils)))
        (snippet
         '(begin
+           ;; Manually apply upstream's a5cef5b09668513af8f898e2402377ebd58a64cc
+           ;; fix.  See <https://issues.guix.gnu.org/issue/40374>.
+           (rename-file "src/effects/icons/color shift.png"
+                        "src/effects/icons/colorshift.png")
            (delete-file-recursively "src/images/fonts") #t))))
     (build-system python-build-system)
     (inputs