summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-03-24 01:44:05 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-03-24 09:30:02 +0300
commitbba66e7a600b35159d20e41df7c18fc1ec764dd9 (patch)
tree1d9a9ee466a6c2973b8b4be0cc287b05a6372cdd /gnu/packages/video.scm
parent8e88f6fa8236a1fe66912957ecacae348355ec15 (diff)
downloadguix-bba66e7a600b35159d20e41df7c18fc1ec764dd9.tar.gz
gnu: streamlink: Update to 0.11.0.
* gnu/packages/video.scm (streamlink): Update to 0.11.0.
[native-inputs]: Add python-urllib3.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f7f82df072..b19581a46c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1753,14 +1753,14 @@ and custom quantization matrices.")
 (define-public streamlink
   (package
     (name "streamlink")
-    (version "0.10.0")
+    (version "0.11.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "streamlink" version))
        (sha256
         (base32
-         "17299xnd9jzi7m1d2rr4xdlj47q64bzj2957nlsrhw0hskds1s6h"))))
+         "02h8b3k8l5zz4vjm0nhxvl1pm924jms8y7sjl40fbybrzvsa4mg2"))))
     (build-system python-build-system)
     (home-page "https://github.com/streamlink/streamlink")
     (native-inputs
@@ -1773,7 +1773,8 @@ and custom quantization matrices.")
        ("python-iso3166" ,python-iso3166)
        ("python-iso639" ,python-iso639)
        ("python-pycryptodome" ,python-pycryptodome)
-       ("python-requests" ,python-requests)))
+       ("python-requests" ,python-requests)
+       ("python-urllib3" ,python-urllib3)))
     (synopsis "Extract streams from various services")
     (description "Streamlink is command-line utility that extracts streams
 from sites like Twitch.tv and pipes them into a video player of choice.")