summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-08-05 00:44:53 -0400
committer宋文武 <iyzsong@member.fsf.org>2022-08-10 16:27:48 +0800
commit37ea0a7360f88e213e2dc3616c259d7fd4d2b6fd (patch)
tree6cc1616256294ec06d2c499bc8c325e547b097a5 /gnu/packages/video.scm
parent6ff0e43d4ef80b81599cb66432f80784deefc704 (diff)
downloadguix-37ea0a7360f88e213e2dc3616c259d7fd4d2b6fd.tar.gz
gnu: openh264: Update to 2.3.0 and use gexps.
* gnu/packages/video.scm (openh264): Update to 2.3.0.
[arguments]: Use gexps.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 44ae49ac1c..d5dc59ddff 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3939,7 +3939,7 @@ post-processing of video formats like MPEG2, H.264/AVC, and VC-1.")
 (define-public openh264
   (package
     (name "openh264")
-    (version "2.1.1")
+    (version "2.3.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3948,17 +3948,20 @@ post-processing of video formats like MPEG2, H.264/AVC, and VC-1.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0ffav46pz3sbj92nipd62z03fibyqgclfq9w8lgr80s6za6zdk5s"))))
+                "1yr6nsjpnazq4z6dvjfyanljwgwnyjh3ddxa0sq6hl9qc59yq91r"))))
     (build-system gnu-build-system)
     (native-inputs
      (list nasm python))
     (arguments
-     '(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
-                          "CC=gcc")
-       #:test-target "test"
-       #:phases (modify-phases %standard-phases
-                  ;; no configure script
-                  (delete 'configure))))
+     (list
+      #:make-flags
+      #~(list (string-append "PREFIX=" #$output)
+                             "CC=gcc")
+      #:test-target "test"
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; no configure script
+          (delete 'configure))))
     (home-page "https://www.openh264.org/")
     (synopsis "H264 decoder library")
     (description