summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-10-22 15:13:06 -0400
committerLeo Famulari <leo@famulari.name>2021-11-01 10:09:27 -0400
commit7eaacf0ece04e10a9f618893222c94b11216227c (patch)
treef020b719b65368ad7dd6b3d2d3b6fafa7728d969 /gnu/packages/video.scm
parentc4ca2e95581c07bfef3dcbbfbca1cc51f0598bef (diff)
downloadguix-7eaacf0ece04e10a9f618893222c94b11216227c.tar.gz
gnu: libopenshot: Update to 0.2.7.
* gnu/packages/video.scm (libopenshot): Update to 0.2.7.
[origin]: Adjust snippet to upstream changes.
[inputs]: Add alsa-lib and zlib.
[propagated-inputs]: Replace ffmpeg-4.3 with ffmpeg.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 540b81f0b3..6ed49ce5a5 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4659,7 +4659,7 @@ create smoother and stable videos.")
 (define-public libopenshot
   (package
     (name "libopenshot")
-    (version "0.2.5")
+    (version "0.2.7")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -4668,11 +4668,11 @@ create smoother and stable videos.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1mxjkgjmjzgf628y3rscc6rqf55hxgjpmvwxlncfk1216i5xskwp"))
+                "0i9bsn8gklm1mvj60l3d3xrxdgy8svpxjfqcwsr308j5zjn30pv8"))
               (modules '((guix build utils)))
               (snippet '(begin
                           ;; Allow overriding of the python installation dir
-                          (substitute* "src/bindings/python/CMakeLists.txt"
+                          (substitute* "bindings/python/CMakeLists.txt"
                             (("(SET\\(PYTHON_MODULE_PATH.*)\\)" _ set)
                              (string-append set " CACHE PATH "
                                             "\"Python bindings directory\")")))
@@ -4684,11 +4684,12 @@ create smoother and stable videos.")
        ("python" ,python)
        ("swig" ,swig)
        ("unittest++" ,unittest-cpp)))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("zlib" ,zlib)))
     (propagated-inputs                  ;all referenced in installed headers
      `(("cppzmq" ,cppzmq)
-       ;; libopenshot doesn't yet build with ffmpeg 4.4 (see:
-       ;; https://github.com/OpenShot/libopenshot/issues/676).
-       ("ffmpeg" ,ffmpeg-4.3)
+       ("ffmpeg" ,ffmpeg)
        ("imagemagick" ,imagemagick)
        ("jsoncpp" ,jsoncpp)
        ("libopenshot-audio" ,libopenshot-audio)