summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-07 02:30:25 -0400
committerMark H Weaver <mhw@netris.org>2015-07-07 10:52:04 -0400
commit23da88f61e82e2b32d6dedb3af467f665cd03bf5 (patch)
treedc58ab24ba57f3b7cfae50639e80a5a2f9ba5d21 /gnu/packages/video.scm
parent4ca5c91f65bdc5a90e30991d2cc346667b54ceee (diff)
downloadguix-23da88f61e82e2b32d6dedb3af467f665cd03bf5.tar.gz
gnu: liba52: Build shared library.
* gnu/packages/patches/liba52-enable-pic.patch,
  gnu/packages/patches/liba52-link-with-libm.patch,
  gnu/packages/patches/liba52-set-soname.patch,
  gnu/packages/patches/liba52-use-mtune-not-mcpu.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/video.scm (liba52)[source]: Add patches.
  [native-inputs]: Add autoconf, automake, and libtool.
  [arguments]: Add "--enable-shared" to configure-flags.
  Add 'bootstrap' phase.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm23
1 files changed, 20 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0c2c7d47a2..259e858e7d 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -128,15 +128,32 @@ old-fashioned output methods with powerful ascii-art renderer.")
                     ".tar.gz"))
               (sha256
                (base32
-                "0czccp4fcpf2ykp16xcrzdfmnircz1ynhls334q374xknd5747d2"))))
+                "0czccp4fcpf2ykp16xcrzdfmnircz1ynhls334q374xknd5747d2"))
+              (patches (map search-patch '("liba52-enable-pic.patch"
+                                           "liba52-set-soname.patch"
+                                           "liba52-use-mtune-not-mcpu.patch"
+                                           "liba52-link-with-libm.patch")))))
     (build-system gnu-build-system)
+    ;; XXX We need to run ./bootstrap because of the build system fixes above.
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
     (arguments `(#:configure-flags
-                 '(;; FIXME: liba52-0.7.4's config.guess fails on mips64el.
+                 '("--enable-shared"
+                   ;; FIXME: liba52-0.7.4's config.guess fails on mips64el.
                    ,@(if (%current-target-system)
                          '()
                          (let ((triplet
                                 (nix-system->gnu-triplet (%current-system))))
-                           (list (string-append "--build=" triplet)))))))
+                           (list (string-append "--build=" triplet)))))
+                 #:phases
+                 (modify-phases %standard-phases
+                   ;; XXX We need to run ./bootstrap because of the build
+                   ;; system fixes above.
+                   (add-after
+                    'unpack 'bootstrap
+                    (lambda _ (zero? (system* "sh" "bootstrap")))))))
     (home-page "http://liba52.sourceforge.net/")
     (synopsis "ATSC A/52 stream decoder")
     (description "liba52 is a library for decoding ATSC A/52 streams.  The