summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-10 14:54:30 -0400
committerMark H Weaver <mhw@netris.org>2015-07-15 13:36:58 -0400
commit3a286b959401f8ea025c8985c4dd9e80bb53d575 (patch)
tree1861ba0b61b78b22834bc8c35f84c0c2fad79f8e /gnu/packages/video.scm
parent46472ecd006e7fd5e36056b2c7a0f3023d4efbd7 (diff)
downloadguix-3a286b959401f8ea025c8985c4dd9e80bb53d575.tar.gz
gnu: mplayer: Enable use of NEON on armhf.
* gnu/packages/video.scm (mplayer)[arguments]: Remove "--disable-neon" from
  arguments passed to configure.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0af5a3e13e..9a0e959d54 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -658,7 +658,6 @@ treaming protocols.")
                                     (or (%current-target-system)
                                         (nix-system->gnu-triplet
                                          (%current-system)))))))
-                      "--disable-neon"
                       "--disable-iwmmxt"))))
           %standard-phases)))
     (home-page "http://www.mplayerhq.hu/design7/news.html")
@@ -898,23 +897,6 @@ projects while introducing many more.")
                      (zero? (system* "./configure"
                                      "--enable-shared"
                                      "--as=yasm"
-                                     ,@(if (and (not (%current-target-system))
-                                                (string-prefix?
-                                                 "armhf-"
-                                                 (%current-system)))
-                                           ;; When building on ARMv7, libvpx
-                                           ;; assumes that NEON will be
-                                           ;; available.  On Guix, armhf
-                                           ;; does not require NEON, so we
-                                           ;; build for ARMv6 and -marm (since
-                                           ;; no thumb2 on ARMv6) to ensure
-                                           ;; compatibility with all ARMv7
-                                           ;; cores we support.  Based on
-                                           ;; the Debian libvpx package.
-                                           '("--target=armv6-linux-gcc"
-                                             "--extra-cflags=-marm"
-                                             "--enable-small")
-                                           '())
                                      (string-append "--prefix=" out)))))
                  %standard-phases)
        #:tests? #f)) ; no check target