summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2017-06-01 23:32:43 +0200
committerClément Lassieur <clement@lassieur.org>2017-06-04 10:11:29 +0200
commit2aaa57294e1980795e0be6b28a40b95b280be1ba (patch)
treec48dbf5ec0ab7324722cdcbbf0e495b7b29817eb /gnu/packages/video.scm
parentfa379a5b45ebe5662ed4cdebf3877f9a12625ba1 (diff)
downloadguix-2aaa57294e1980795e0be6b28a40b95b280be1ba.tar.gz
gnu: vlc: Use livemedia-utils.
* gnu/packages/video.scm (vlc)[inputs]: Add livemedia-utils.
[native-inputs]: Add autoconf, automake and libtool.
[arguments]: Add bootstrap and fix-livemedia-utils-prefix phases.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 95f17462d6..8b8140eb96 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -660,7 +660,10 @@ audio/video codec library.")
                "1a22b913p2227ljz89c4fgjlyln5gcz8z58w32r0wh4srnnd60y4"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("git" ,git) ; needed for a test
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("git" ,git) ; needed for a test
+       ("libtool" ,libtool)
        ("pkg-config" ,pkg-config)))
     ;; FIXME: Add optional inputs once available.
     (inputs
@@ -688,6 +691,7 @@ audio/video codec library.")
        ("libxinerama" ,libxinerama)
        ("libxml2" ,libxml2)
        ("libxpm" ,libxpm)
+       ("livemedia-utils" ,livemedia-utils)
        ("lua" ,lua-5.1)
        ("mesa" ,mesa)
        ("opus" ,opus)
@@ -715,6 +719,15 @@ audio/video codec library.")
 
        #:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'bootstrap
+           (lambda _ (zero? (system* "sh" "bootstrap"))))
+         (add-before 'bootstrap 'fix-livemedia-utils-prefix
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((livemedia-utils (assoc-ref inputs "livemedia-utils")))
+               (substitute* "configure.ac"
+                 (("LIVE555_PREFIX=\\$\\{LIVE555_PREFIX-\"/usr\"\\}")
+                  (string-append "LIVE555_PREFIX=" livemedia-utils)))
+               #t)))
          (add-before 'configure 'remove-visual-tests
            ;; Some of the tests require using the display to test out VLC,
            ;; which fails in our sandboxed build system