summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-12-21 15:53:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-17 20:43:51 +0200
commitd5650f86a7e3f16512af498bfa998398f11c3e8a (patch)
tree996ca0c4d42a9b8f6c04731c0d28361abd1bb40b /gnu/packages/video.scm
parent2328b47c643bc32bb823045628f4814885d6204d (diff)
downloadguix-d5650f86a7e3f16512af498bfa998398f11c3e8a.tar.gz
gnu: Add libvdpau.
* gnu/packages/video.scm (libvdpau): New variable.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 752e51d0a7..baeb747fe6 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1299,3 +1299,29 @@ from many input sources such as webcams, X11 (for screencasting), PulseAudio,
 and JACK.")
     (home-page "https://obsproject.com")
     (license license:gpl2+)))
+
+(define-public libvdpau
+  (package
+    (name "libvdpau")
+    (version "1.1.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://secure.freedesktop.org/~aplattner/vdpau/"
+                            name "-" version ".tar.bz2"))
+        (sha256
+         (base32
+          "0dnpb0yh7v6rvckx82kxg045rd9rbsw25wjv7ad5n8h94s9h2yl5"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("dri2proto" ,dri2proto)
+       ("libx11" ,libx11 "out")
+       ("libxext" ,libxext)))
+    (home-page "https://wiki.freedesktop.org/www/Software/VDPAU/")
+    (synopsis "Video Decode and Presentation API")
+    (description "VDPAU is the Video Decode and Presentation API for UNIX.  It
+provides an interface to video decode acceleration and presentation hardware
+present in modern GPUs.")
+    (license (license:x11-style "file://COPYING"))))