summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-29 21:47:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-29 22:43:48 +0100
commit21309b8b1fafa4267dcbfa85e3b0a416d4fbdb95 (patch)
tree8b942a0dbddc89ab6fa0d6f43cad47bd2ec174dc /gnu/packages/video.scm
parent2f069a1fa7d3ce171a917b340fee8305d12d0f83 (diff)
downloadguix-21309b8b1fafa4267dcbfa85e3b0a416d4fbdb95.tar.gz
gnu: simplescreenrecorder: Fetch sources from git.
* gnu/packages/video.scm (simplescreenrecorder)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 1fdcecb4d4..d246f402ce 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2267,13 +2267,14 @@ making @dfn{screencasts}.")
     (version "0.3.11")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/MaartenBaert/ssr/archive/"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/MaartenBaert/ssr.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0l6irdadqpajvv0dj3ngs1231n559l0y1pykhs2h7526qm4w7xal"))))
+         "0n702dnv4qshgn3b90ixvplfafjhgz6040yir5vy8khjdpciysq4"))))
     (build-system cmake-build-system)
     ;; Although libx11, libxfixes, libxext are listed as build dependencies in
     ;; README.md, the program builds and functions properly without them.