summary refs log tree commit diff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-26 09:56:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-26 09:56:45 +0200
commit1abeb6c907c17107bfba6aa11b58bda74433657b (patch)
tree21fee72d36f5c0b7945ab9bebebcca903cea5ddb /gnu/packages/vim.scm
parent18c3d347f5b24767093b13ece16df2b90c7894ad (diff)
downloadguix-1abeb6c907c17107bfba6aa11b58bda74433657b.tar.gz
gnu: vim-coqtail: Use vim-build-system.
* gnu/packages/vim.scm (vim-coqtail)[build-system]: Switch to the
vim-build-system.
[arguments]: Remove install-plan.  Add plugin-name.  Adjust custom
'check phase to refer to vim-full.
[native-inputs]: Use 'old-style' package references to be able to
specify vim-full.

Change-Id: Iae3877738032a5583320245f63775f187c40fb6a
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 2dc59af83d..1e204b9533 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -467,16 +467,9 @@ trouble using them, because you do not have to remember each snippet name.")
                 (sha256
                  (base32
                   "0av2m075n6z05ah9ndrgnp9s16yrz6n2lj0igd9fh3c5k41x5xks"))))
-      (build-system copy-build-system)
+      (build-system vim-build-system)
       (arguments
-       '(#:install-plan
-         '(("autoload" "share/vim/vimfiles/")
-           ("doc" "share/vim/vimfiles/")
-           ("ftdetect" "share/vim/vimfiles/")
-           ("ftplugin" "share/vim/vimfiles/")
-           ("indent" "share/vim/vimfiles/")
-           ("python" "share/vim/vimfiles/")
-           ("syntax" "share/vim/vimfiles/"))
+       '(#:plugin-name "coqtail"
          #:phases
          (modify-phases %standard-phases
            (add-before 'install 'check
@@ -497,17 +490,20 @@ trouble using them, because you do not have to remember each snippet name.")
                                       "/share/vim/vimfiles/pack/guix/start/vader")))
                    (with-directory-excursion "tests/vim"
                      (setenv "VADER_PATH" vader-path)
-                     (invoke "vim" "-E" "-Nu" "vimrc"
+                     (invoke (string-append
+                               (assoc-ref (or native-inputs inputs) "vim-full")
+                               "/bin/vim")
+                             "-E" "-Nu" "vimrc"
                              "-c" "Vader! *.vader")))
 
                  ;; Remove __pycache__ files generated during testing so that
                  ;; they don't get installed.
                  (delete-file-recursively "python/__pycache__")))))))
       (native-inputs
-       (list coq-for-coqtail
-             python-pytest
-             vim-full ;; Plugin needs Python 3.
-             vim-vader))
+       `(("coq-for-coqtail" ,coq-for-coqtail)
+         ("python-pytest" ,python-pytest)
+         ("vim-full" ,vim-full)         ; Plugin needs Python 3.
+         ("vim-vader" ,vim-vader)))
       (propagated-inputs (list coq coq-ide-server))
       (synopsis "Interactive Coq proofs in Vim")
       (description "Coqtail enables interactive Coq proof development in Vim