summary refs log tree commit diff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-17 17:29:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-09 22:10:12 -0500
commitedb03ceb60d2f44162332878b1d1a1a34b5fd6a3 (patch)
tree4744ae37671ca06fcc2fbe16b220bcbd7883fc4d /gnu/packages/vim.scm
parent504b46cd87dae437fec1949aeed2394951a92f77 (diff)
downloadguix-edb03ceb60d2f44162332878b1d1a1a34b5fd6a3.tar.gz
gnu: msgpack: Deprecate with msgpack-c.
* gnu/packages/serialization.scm (msgpack-c): New variable.
(msgpack-cxx): New variable.
(msgpack): Rename to...
(msgpack-3): ... this, and inherit from msgpack-c.
* gnu/packages/vim.scm (eovim) [arguments]: Add help-cmake-find-msgpack-c
phase.
[inputs]: Replace msgpack with msgpack-c.
* gnu/packages/terminals.scm (tmate)
[inputs]: Replace msgpack with msgpack-3.
* gnu/packages/networking.scm (opendht)
[propagated-inputs]: Replace msgpack with msgpack-cxx.
* gnu/packages/chemistry.scm (mmtf-cpp) [propagated-inputs]: Likewise.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 1f7a005cb1..e301088394 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -884,6 +884,14 @@ refactor Vim in order to:
      '(#:tests? #false ;no tests
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'help-cmake-find-msgpack-c
+           (lambda _
+             ;; Patch the build system so that it can find the modern
+             ;; 'msgpack-c' named pkg-config file (see:
+             ;; https://github.com/jeanguyomarch/eovim/issues/73).
+             (substitute* "cmake/Modules/FindMsgPack.cmake"
+               (("MSGPACK QUIET msgpack")
+                "MSGPACK QUIET msgpack-c msgpack"))))
          (add-after 'configure 'reference-nvim
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((nvim (search-input-file inputs "/bin/nvim")))
@@ -894,10 +902,8 @@ refactor Vim in order to:
                   (string-append start nvim))))))
          (add-before 'build 'set-home
            (lambda _ (setenv "HOME" "/tmp"))))))
-    (native-inputs
-     (list pkg-config))
-    (inputs
-     (list efl msgpack neovim))
+    (native-inputs (list pkg-config))
+    (inputs (list efl msgpack-c neovim))
     (home-page "https://github.com/jeanguyomarch/eovim/")
     (synopsis "EFL GUI for Neovim")
     (description "Graphical Neovim interface based on the @acronym{EFL, Enlightenment