summary refs log tree commit diff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorng0 <contact.ng0@cryptolab.net>2017-02-14 13:18:24 +0000
committerKei Kebreau <kei@openmailbox.org>2017-02-28 12:25:20 -0500
commit25340002b6f6d54737eef6878b0569c5c1ff27bc (patch)
treee4ca8cbfb628e41947b54a1b72a2ab1ffe6b0a2f /gnu/packages/vim.scm
parenta4c95372e28c73ec8f8a5aaba53b6de39185fc25 (diff)
downloadguix-25340002b6f6d54737eef6878b0569c5c1ff27bc.tar.gz
gnu: Add vim-context-filetype.
* gnu/packages/vim.scm (vim-context-filetype): New variable.

Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index b80b3f2ebf..c702b9011b 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -372,6 +372,45 @@ trouble using them, because you do not have to remember each snippet name.")
       (home-page "https://github.com/notpratheek/vim-luna")
       (license license:expat))))
 
+;; There are no tarball releases.
+(define-public vim-context-filetype
+  (let ((commit "5e85f8cae26806f391aefe2661791a6de53bcea2")
+        (revision "1"))
+    (package
+      (name "vim-context-filetype")
+      (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Shougo/context_filetype.vim")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32
+           "0alvrfhmd91zkd9h83s8wvgyq4iakcf6rybsyjd369qbgpcqky89"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)
+           (delete 'build)
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out"))
+                      (vimfiles (string-append out "/share/vim/vimfiles"))
+                      (doc (string-append vimfiles "/doc"))
+                      (autoload (string-append vimfiles "/autoload")))
+                 (copy-recursively "doc" doc)
+                 (copy-recursively "autoload" autoload)
+                 #t))))))
+      (synopsis "Context filetype library for Vim")
+      (description
+       "@code{vim-context-filetype} is context filetype library for Vim script.")
+      (home-page "https://github.com/Shougo/context_filetype.vim")
+      (license license:expat)))) ; ??? check again
+
 (define-public neovim
   (package
     (name "neovim")