summary refs log tree commit diff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorng0 <contact.ng0@cryptolab.net>2017-02-14 13:18:22 +0000
committerKei Kebreau <kei@openmailbox.org>2017-02-28 12:25:17 -0500
commit5890f891e7c95119ab0931fb6320850331b6a432 (patch)
tree47caf023a9b1c70a7370faf1671b6a36369c8d99 /gnu/packages/vim.scm
parent34af179ac73e4dd01ec3b3e311db21c6ad18c90d (diff)
downloadguix-5890f891e7c95119ab0931fb6320850331b6a432.tar.gz
gnu: Add vim-neosnippet.
* gnu/packages/vim.scm (vim-neosnippet): New variable.

Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index a2c86e5c0a..ca8cb5637f 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -239,6 +239,63 @@ you can fill in on the fly.")
     (home-page "https://github.com/Shougo/neosnippet-snippets")
     (license license:expat))))
 
+;; The released tarball is too old for our Vim.
+(define-public vim-neosnippet
+  (let ((commit "1bd7e23c79b73da16eb0c9469b25c376d3594583")
+        (revision "1"))
+  (package
+    (name "vim-neosnippet")
+    (version (string-append "4.2-" revision "." (string-take commit 7)))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Shougo/neosnippet.vim/")
+             (commit commit)))
+       (file-name (string-append name "-" version "-checkout"))
+       (sha256
+        (base32
+         "0k80syscmpnj38ks1fq02ds59g0r4jlg9ll7z4qc048mgi35alw5"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (delete 'build)
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (vimfiles (string-append out "/share/vim/vimfiles"))
+                    (autoload (string-append vimfiles "/autoload"))
+                    (doc (string-append vimfiles "/doc"))
+                    (ftdetect (string-append vimfiles "/ftdetect"))
+                    (ftplugin (string-append vimfiles "/ftplugin"))
+                    (indent (string-append vimfiles "/indent"))
+                    (plugin (string-append vimfiles "/plugin"))
+                    (rplugin (string-append vimfiles "/rplugin"))
+                    (syntax (string-append vimfiles "/syntax")))
+               (copy-recursively "autoload" autoload)
+               (copy-recursively "doc" doc)
+               (copy-recursively "ftdetect" ftdetect)
+               (copy-recursively "ftplugin" ftplugin)
+               (copy-recursively "indent" indent)
+               (copy-recursively "plugin" plugin)
+               (copy-recursively "rplugin" rplugin)
+               (copy-recursively "syntax" syntax)
+               #t))))))
+    (synopsis "Snippet support for Vim")
+    (description
+     "@code{neosnippet}, is a plugin for Vim which adds snippet support to Vim.
+Snippets are small templates for commonly used code that you can fill in on
+the fly.  To use snippets can increase your productivity in Vim a lot.
+The functionality of this plug-in is quite similar to plug-ins like
+@code{snipMate.vim} or @code{snippetsEmu.vim}.  But since you can choose
+snippets with the neocomplcache / neocomplete interface, you might have less
+trouble using them, because you do not have to remember each snippet name.")
+    (home-page "https://github.com/Shougo/neosnippet.vim/")
+    (license license:expat))))
+
 (define-public vim-scheme
   (let ((commit "93827987c10f2d5dc519166a761f219204926d5f")
         (revision "1"))