summary refs log tree commit diff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorng0 <contact.ng0@cryptolab.net>2017-02-14 13:18:23 +0000
committerKei Kebreau <kei@openmailbox.org>2017-02-28 12:25:20 -0500
commita4c95372e28c73ec8f8a5aaba53b6de39185fc25 (patch)
tree811398c66e29edf5217d2ee6f4d7a6162803b8ac /gnu/packages/vim.scm
parent5890f891e7c95119ab0931fb6320850331b6a432 (diff)
downloadguix-a4c95372e28c73ec8f8a5aaba53b6de39185fc25.tar.gz
gnu: Add vim-luna.
* gnu/packages/vim.scm (vim-luna): New variable.

Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index ca8cb5637f..b80b3f2ebf 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -336,6 +336,42 @@ trouble using them, because you do not have to remember each snippet name.")
       (home-page "http://foldling.org/git/vim-scheme.git/")
       (license license:public-domain))))
 
+(define-public vim-luna
+  (let ((commit "633619953dcf8577168e255230f96b05f28d6371")
+        (revision "1"))
+    (package
+      (name "vim-luna")
+      (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/notpratheek/vim-luna")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32
+           "0ka3qbhsh8lix1vyj4678j7dnchkd8khhirrnn3aylxxf8fpqyg8"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)
+           (delete 'build)
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out"))
+                      (vimfiles (string-append out "/share/vim/vimfiles"))
+                      (colors (string-append vimfiles "/colors")))
+                 (copy-recursively "colors" colors)
+                 #t))))))
+      (synopsis "Dark color theme for Vim")
+      (description
+       "@code{vim-luna} is a dark color theme for Vim.")
+      (home-page "https://github.com/notpratheek/vim-luna")
+      (license license:expat))))
+
 (define-public neovim
   (package
     (name "neovim")