summary refs log tree commit diff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-05-25 15:41:15 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-06-04 13:34:46 +0200
commit09be86744f296b54680755fd873c22602b739ad8 (patch)
tree314577b6c31a1d4fb023571fc82b1b3a251e52f4 /gnu/packages/vim.scm
parentf5f78d0d0227e80d00cafa1861a8a72a180de074 (diff)
downloadguix-09be86744f296b54680755fd873c22602b739ad8.tar.gz
gnu: neovim: Use 'inputs' in phases instead of '%build-inputs'.
In build phases, the former is preferred.

* gnu/packages/vim.scm
  (neovim)[arguments]<#:phases>{set-lua-path}: Use 'inputs'
  argument instead of '%build-inputs'.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index ebab790ee0..238c25d486 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -695,7 +695,7 @@ are detected, the user is notified.")))
                      (lambda (prefix)
                        (let ((path (string-append prefix "/share/lua/" lua-version)))
                          (string-append path "/?.lua;" path "/?/?.lua"))))
-                    (lua-inputs (map (cute assoc-ref %build-inputs <>)
+                    (lua-inputs (map (cute assoc-ref inputs <>)
                                      '("lua"
                                        "lua-luv"
                                        "lua-lpeg"