summary refs log tree commit diff
path: root/gnu/packages/vlang.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-06 01:01:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-06 01:04:47 +0200
commit84fa2ced47e16de66674ca169845a6f08cb5ef6c (patch)
treee8c820ff47812d926706e5b5f5ca2861d90e7a05 /gnu/packages/vlang.scm
parent4af2cef5e9194e59f252dc6247c35292d42a2dd3 (diff)
downloadguix-84fa2ced47e16de66674ca169845a6f08cb5ef6c.tar.gz
gnu: vlang: Update to 0.1.29.
* gnu/packages/vlang.scm (vlang): Update to 0.1.29.
Diffstat (limited to 'gnu/packages/vlang.scm')
-rw-r--r--gnu/packages/vlang.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/vlang.scm b/gnu/packages/vlang.scm
index 70133bb233..42dd27a915 100644
--- a/gnu/packages/vlang.scm
+++ b/gnu/packages/vlang.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -26,7 +27,7 @@
 (define-public vlang
   (package
    (name "vlang")
-   (version "0.1.27")
+   (version "0.1.29")
    (source
     (origin
      (method git-fetch)
@@ -35,20 +36,19 @@
            (commit version)))
      (file-name (git-file-name name version))
      (sha256
-      (base32 "1d9qhacllvkqif42jaayixhjyhx7pzslh8p1yr5p19447q763fq1"))))
+      (base32 "1rqi7cah5nq8aggrib9xvdpfjxq20li91svv0w9yny6nn1ag7snx"))))
    (build-system gnu-build-system)
    (arguments
-    '(#:tests? #f ; tests are broken in v 0.1.27
+    '(#:tests? #f                      ; some tests are broken
       #:make-flags
       `("CC=gcc"
+        "TMPTCC=tcc"
+        ,(string-append "VC=" (assoc-ref %build-inputs "vc"))
         "GITCLEANPULL=true"
         "GITFASTCLONE=mkdir -p"
         "TCCREPO="
-        "TMPTCC=tcc"
-        ,(string-append "TMPVC=" (assoc-ref %build-inputs "vc"))
         "VCREPO="
-        "VERBOSE=1"
-        "V_ALWAYS_CLEAN_TMP=false")
+        "VERBOSE=1")
       #:phases
       (modify-phases %standard-phases
         (delete 'configure)
@@ -90,7 +90,9 @@
     `(("glib" ,glib)))
    (native-inputs
     `(("vc"
-       ,(let ((vc-version "0884d7092f4c2a4f8ca16da6f1792efa235247be"))
+       ;; Versions are not consistently tagged, but the matching commit will
+       ;; probably have ‘v0.x.y’ in the commit message.
+       ,(let ((vc-version "b01d0fcda4b55861baa4be82e307cca4834b1641"))
           ;; v bootstraps from generated c source code from a dedicated
           ;; repository. It's readable, as generated source goes, and not at all
           ;; obfuscated, and it's about 15kb. The original source written in
@@ -104,7 +106,7 @@
                   (commit vc-version)))
             (file-name (git-file-name "vc" vc-version))
             (sha256
-             (base32 "17bs09iwxfd0si70j48n9nd16gfgcj8imd0azypk3xzzbz4wybnz")))))))
+             (base32 "052gp5q2k31r3lci3rx4k0vy0vjdjva64xvrbbihn8lgmw63lc9f")))))))
    (home-page "https://vlang.io/")
    (synopsis "Compiler for the V programming language")
    (description