summary refs log tree commit diff
path: root/gnu/packages/vnc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-12-30 10:53:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-12-30 10:53:39 +0200
commitccb402d9db0ee1c37866fa1382841183b48f3a2a (patch)
treef35acb2d45879903f36ff1a595609b8b84cb3691 /gnu/packages/vnc.scm
parent78cf7a4571081ff9c9e4ab678bf67368de1add59 (diff)
parent4303e33c8636d9c3bfe03758f25636efa9674af9 (diff)
downloadguix-ccb402d9db0ee1c37866fa1382841183b48f3a2a.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/vnc.scm')
-rw-r--r--gnu/packages/vnc.scm86
1 files changed, 44 insertions, 42 deletions
diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index ab89bad7aa..b8979b2921 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -1,8 +1,9 @@
-;;; GNU Guix --- Functional package management for GNU
+;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 Todor Kondić <tk.code@protonmail.com>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -41,55 +42,56 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages sdl)
   #:use-module (gnu packages tls)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg))
 
 (define-public tigervnc-client
-  (let ((commit "920d9c4d6562ecabf79497bc901d50522d4bc661"))
-    (package
-      (name "tigervnc-client")
-      (version (git-version "1.10.1" "1" commit))
-      (source (origin
-                (method git-fetch)
-                (uri
-                 (git-reference
-                  (url "https://github.com/TigerVNC/tigervnc")
-                  (commit commit)))
-                (sha256
-                 (base32
-                  "1lp6mxl5dqlkrzx0q145jzgpbwvhsni3fj6x9ngf8v5s63x82q1p"))
-                (file-name (git-file-name name version))))
-      (build-system cmake-build-system)
-      (arguments
-       '(#:tests? #f ; Tests that do exists are not automated.
-         #:phases (modify-phases %standard-phases
-                    (replace 'install
-                      (lambda* (#:key outputs #:allow-other-keys)
-                        (with-directory-excursion "vncviewer"
-                          (invoke "make" "install")))))))
-      (native-inputs
-       `(("autoconf" ,autoconf)
-         ("gettext-minimal" ,gettext-minimal)
-         ("automake" ,automake)))
-      (inputs
-       `(("zlib" ,zlib)
-         ("gnutls" ,gnutls)
-         ("libjpeg-turbo" ,libjpeg-turbo)
-         ("fltk" ,fltk)
-         ("linux-pam" ,linux-pam)
-         ("libx11" ,libx11)
-         ("libxext" ,libxext)
-         ("libxtst" ,libxtst)
-         ("libxrandr" ,libxrandr)
-         ("libxdamage" ,libxdamage)))
-      (home-page "https://tigervnc.org/")
-      (synopsis "High-performance, platform-neutral
+  (package
+    (name "tigervnc-client")
+    (version "1.11.0")
+    (source (origin
+              (method git-fetch)
+              (uri
+               (git-reference
+                (url "https://github.com/TigerVNC/tigervnc")
+                (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "1bg79ahr4mzy48ak0caxy3ckdsxmhpchypggaz6lxjjk92hgsz91"))
+              (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f ; Tests that do exists are not automated.
+       #:phases (modify-phases %standard-phases
+                  (replace 'install
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (with-directory-excursion "vncviewer"
+                        (invoke "make" "install")))))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("gettext-minimal" ,gettext-minimal)
+       ("automake" ,automake)))
+    (inputs
+     `(("zlib" ,zlib)
+       ("gnutls" ,gnutls)
+       ("libjpeg-turbo" ,libjpeg-turbo)
+       ("fltk" ,fltk)
+       ("linux-pam" ,linux-pam)
+       ("libx11" ,libx11)
+       ("libxext" ,libxext)
+       ("libxtst" ,libxtst)
+       ("libxrandr" ,libxrandr)
+       ("libxdamage" ,libxdamage)
+       ("pixman" ,pixman)))
+    (home-page "https://tigervnc.org/")
+    (synopsis "High-performance, platform-neutral
 implementation of VNC (client)")
-      (description "TigerVNC is a client/server implementation of VNC (Virtual
+    (description "TigerVNC is a client/server implementation of VNC (Virtual
 Network Computing).  It provides enough performance to run even 3D and video
 applications.  It also provides extensions for advanced authentication methods
 and TLS encryption.  This package installs only the VNC client, the
 application which is needed to connect to VNC servers.")
-      (license license:gpl2))))
+    (license license:gpl2)))
 
 ;; A VNC server is, in fact, an X server so it seems like a good idea
 ;; to build on the work already done for xorg-server package.  This is