summary refs log tree commit diff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-03-02 23:42:56 -0500
committerLeo Famulari <leo@famulari.name>2020-03-03 00:37:41 -0500
commitc1005113a3e8e2d59f63d9e6a0a6176c7f67421f (patch)
tree94a45aa95e61a63b3b7a96563f07db31041d9af3 /gnu/packages/vpn.scm
parent85a7466e22d345444f952b57346f4c09de020c1f (diff)
downloadguix-c1005113a3e8e2d59f63d9e6a0a6176c7f67421f.tar.gz
gnu: WireGuard: Simplify package definitions.
* gnu/packages/vpn.scm (wireguard-tools, wireguard)[arguments]: Set --directory
in #:make-flags and remove the 'chdir', 'enter-source-directory' and 'reset-cwd'
phases.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm29
1 files changed, 6 insertions, 23 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 78a2c322af..a6bba28db1 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -8,7 +8,7 @@
 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
-;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2019, 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;;
@@ -471,6 +471,7 @@ The peer-to-peer VPN implements a Layer 2 (Ethernet) network between the peers
      `(#:tests? #f ; No tests available.
        #:make-flags
        (list "CC=gcc"
+             "--directory=src/tools"
              "WITH_BASHCOMPLETION=yes"
              ;; Build and install the helper script wg-quick(8).
              "WITH_WGQUICK=yes"
@@ -498,17 +499,7 @@ The peer-to-peer VPN implements a Layer 2 (Ethernet) network between the peers
                (call-with-output-file output
                  (lambda (port)
                    (format port "~a" str))))
-               #t))
-         (add-after 'make-patch 'chdir
-           (lambda _
-             (chdir "src/tools")
-             #t))
-         ;; Otherwise the 'install-license-file' phase installs nothing.
-         ;; <https://bugs.gnu.org/34703>
-         (add-after 'install 'reset-cwd
-           (lambda _
-             (chdir "../..")
-             #t)))))
+               #t)))))
     (inputs
      `(("libmnl" ,libmnl)))
     (home-page "https://www.wireguard.com/")
@@ -537,6 +528,7 @@ WireGuard support.")
      `(#:tests? #f                      ; no test suite
        #:make-flags
        (list "CC=gcc"
+             "--directory=src"
              "WITH_BASHCOMPLETION=yes"
              ;; Install the ‘simple and dirty’ helper script wg-quick(8).
              "WITH_WGQUICK=yes"
@@ -545,17 +537,8 @@ WireGuard support.")
              (string-append "SYSCONFDIR=no-thanks"))
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'enter-source-directory
-           (lambda _
-             (chdir "src")
-             #t))
-         (delete 'configure)            ; no configure script
-         (add-after 'install 'reset-cwd
-           ;; Otherwise the 'install-license-file' phase installs nothing.
-           ;; <https://bugs.gnu.org/34703>
-           (lambda _
-             (chdir "..")
-             #t)))))
+         ;; No configure script
+         (delete 'configure))))
     (home-page "https://www.wireguard.com/")
     (synopsis "Tools for configuring WireGuard tunnels")
     (description