summary refs log tree commit diff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-06-22 16:46:09 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-06-22 16:48:58 +0200
commit0919d6148faa40914a6cfe574688734dbda8728d (patch)
treee98ea248b7e76978886593b647756173d2c022fc /gnu/packages/vpn.scm
parent6e31d6f3c478144de1ad185dc7341d5513f464c0 (diff)
downloadguix-0919d6148faa40914a6cfe574688734dbda8728d.tar.gz
gnu: xl2tpd: Fix build.
* gnu/packages/vpn.scm (xl2tpd)[arguments]: Substitute hardcoded pppd path
instead of trying to set CFLAGS variable.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 26cb67661e..e6a2f42ee3 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -648,10 +648,10 @@ public keys and can roam across IP addresses.")
                   (delete 'configure) ;no configure script
                   (add-before 'build 'setup-environment
                     (lambda* (#:key inputs #:allow-other-keys)
-                      (setenv "CFLAGS"
-                              (string-append "-DPPPD=\""
-                                             (assoc-ref inputs "ppp")
-                                             "/sbin/pppd\""))
+                      (substitute* "l2tp.h"
+                        (("/usr/sbin/pppd")
+                         (string-append (assoc-ref inputs "ppp")
+                                        "/sbin/pppd")))
                       (setenv "KERNELSRC"
                               (assoc-ref inputs "linux-libre-headers"))
                       #t)))