summary refs log tree commit diff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-27 23:38:36 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-28 00:01:43 +0200
commitc32863e094d3489d2e08ccb3188988d7c6410976 (patch)
tree17ae60e7de772091b4c3cdfcaf8ea35fbf485062 /gnu/packages/vpn.scm
parent7fed9353ece5974ff431fa666a530da237a12085 (diff)
downloadguix-c32863e094d3489d2e08ccb3188988d7c6410976.tar.gz
gnu: sshuttle: Patch FHS assumptions.
Reported-By: Nam Nguyen <namn@berkeley.edu>

* gnu/packages/vpn.scm (sshuttle)[arguments]: Set correct paths to 'env'
and 'sh'.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 85bbe7e9c6..de5df5039d 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -347,6 +347,17 @@ private network between hosts on the internet.")
         (base32
          "0pqk43kd7crqhg6qgnl8kapncwgw1xgaf02zarzypcw64kvdih9h"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-FHS-file-names
+           (lambda _
+             (substitute* "sshuttle/client.py"
+               (("/usr/bin/env") (which "env")))
+             (substitute* "sshuttle/ssh.py"
+               ;; Perhaps this is unreachable, but don't let's take risks.
+               (("/bin/sh") (which "sh")))
+             #t)))))
     (native-inputs
      `(("python-setuptools-scm" ,python-setuptools-scm)
        ;; For tests only.