summary refs log tree commit diff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-06-21 10:18:19 +0200
committerRutger Helling <rhelling@mykolab.com>2019-06-26 08:34:25 +0200
commit6edbf8de877651495c7b9f6f41e921c501f3c9fb (patch)
tree1b44eb7b6638aa7fda930a7192cd1b236e0221c1 /gnu/packages/vulkan.scm
parent99293380314651858ef2f58bc93429f46b1ce1d8 (diff)
downloadguix-6edbf8de877651495c7b9f6f41e921c501f3c9fb.tar.gz
gnu: vulkan-headers: Update to 1.1.108.
* gnu/packages/vulkan.scm (vulkan-headers): Update to 1.1.108.
* gnu/packages/vulkan.scm (vulkan-loader): Update hash.
[arguments]: Add 'copy-headers1 and 'copy-headers2 phases.
* gnu/packages/vulkan.scm (vulkan-tools): Update hash.
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm30
1 files changed, 26 insertions, 4 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 6b151f0a31..86a0d711eb 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -159,7 +159,7 @@ interpretation of the specifications for these languages.")
 (define-public vulkan-headers
   (package
     (name "vulkan-headers")
-    (version "1.1.107")
+    (version "1.1.108")
     (source
      (origin
        (method git-fetch)
@@ -169,7 +169,7 @@ interpretation of the specifications for these languages.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0kyf83n6fghqmjj5jbwhy08yq5sl598qnmw3kbavrnw9avqqm0c4"))))
+         "0slj10rfcrd6xpfhm13x3q1ldz2qhk9p64cw0nw0qlmy40k1iy83"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f))                    ; No tests.
@@ -193,7 +193,7 @@ interpretation of the specifications for these languages.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1p64k9x5r7nsrs0cn6d61687xbajqvsm78xk6j85w9wfin5dxs30"))))
+         "08v3sdkr0aii4a9jqhyz8j3x42zm2qswsiy6qsb47wz4bpi90zgy"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f ;FIXME: 23/39 tests fail.  Try "tests/run_all_tests.sh".
@@ -203,6 +203,28 @@ interpretation of the specifications for these languages.")
            (lambda* (#:key inputs #:allow-other-keys)
              ;; Remove lines trying to build in a git commit id.
              (substitute* "CMakeLists.txt" ((".*spirv_tools_commit_id.h.*") ""))
+             #t))
+         ;; Make sure that the files needed for Mesa's Vulkan overlay are availabe.
+         (add-after 'unpack 'copy-headers1
+           (lambda* (#:key outputs #:allow-other-keys)
+             (install-file "tests/layers/vk_layer_data.h"
+                           (string-append (assoc-ref %outputs "out")
+                                          "/include/vulkan"))
+             (install-file "tests/layers/vk_layer_extension_utils.h"
+                           (string-append (assoc-ref %outputs "out")
+                                          "/include/vulkan"))
+             (install-file "loader/vk_loader_platform.h"
+                           (string-append (assoc-ref %outputs "out")
+                                          "/include/vulkan"))
+             #t))
+         (add-after 'build 'copy-headers2
+           (lambda* (#:key outputs #:allow-other-keys)
+             (install-file "vk_layer_dispatch_table.h"
+                           (string-append (assoc-ref %outputs "out")
+                                          "/include/vulkan"))
+             (install-file "vk_dispatch_table_helper.h"
+                           (string-append (assoc-ref %outputs "out")
+                                          "/include/vulkan"))
              #t)))
        #:configure-flags (list
                           "-DBUILD_TESTS=OFF" ; FIXME: Needs 'googletest' submodule.
@@ -244,7 +266,7 @@ and the ICD.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1mak96jdg3wv043b4jxyv1fm2cz4nnallg0yb90my3yp5q64grrw"))))
+         "1azch34l9b57wxvh2k5vc0qzmhnapli3348wwhs04z6izszyz4kf"))))
     (build-system cmake-build-system)
     (inputs
      `(("glslang" ,glslang)