summary refs log tree commit diff
path: root/gnu/packages/wdiff.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-26 16:43:08 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-26 16:43:08 +0200
commita9db7d10b6e4e86fb2b87a4161db3b1f202002fd (patch)
tree4a22481ab65447d8bc1cc307a76a884a7e7bbee9 /gnu/packages/wdiff.scm
parente33d9d6f09874f83bb5a03f49cb969a84588e10e (diff)
parent2b6bdf7eb3c95716ac107ea6caea2e0b7077ae77 (diff)
downloadguix-a9db7d10b6e4e86fb2b87a4161db3b1f202002fd.tar.gz
Merge branch 'master' into core-updates
Conflicts:
	Makefile.am
	gnu/packages/autotools.scm
	gnu/packages/guile.scm
	gnu/packages/python.scm
	gnu/packages/shishi.scm
	guix/gnu-maintenance.scm
	guix/scripts/build.scm
	guix/scripts/gc.scm
	guix/scripts/package.scm
	guix/scripts/substitute-binary.scm
	guix/ui.scm
	nix/nix-daemon/guix-daemon.cc
	test-env.in
	tests/nar.scm
	tests/store.scm
Diffstat (limited to 'gnu/packages/wdiff.scm')
-rw-r--r--gnu/packages/wdiff.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/wdiff.scm b/gnu/packages/wdiff.scm
index 02d536c7de..6aa6b2a67a 100644
--- a/gnu/packages/wdiff.scm
+++ b/gnu/packages/wdiff.scm
@@ -21,13 +21,14 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (gnu packages texinfo)
   #:use-module (gnu packages screen)
   #:use-module (gnu packages which))
 
 (define-public wdiff
   (package
     (name "wdiff")
-    (version "1.1.2")
+    (version "1.2.1")
     (source
      (origin
       (method url-fetch)
@@ -35,7 +36,7 @@
                           version ".tar.gz"))
       (sha256
        (base32
-        "0q78y5awvjjmsvizqilbpwany62shlmlq2ayxkjbygmdafpk1k8j"))))
+        "1gb5hpiyikada9bwz63q3g96zs383iskiir0xsqynqnvq1vd4n41"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases (alist-cons-before
@@ -46,10 +47,12 @@
                       (string-append "#!" (which "sh")))))
                  %standard-phases)))
     (inputs `(("screen" ,screen)
-              ("which" ,which)))
+              ("which" ,which)
+
+              ;; For some reason wdiff.info gets rebuilt.
+              ("texinfo" ,texinfo)))
     (home-page "https://www.gnu.org/software/wdiff/")
-    (synopsis
-     "GNU Wdiff, a tool for comparing files on a word by word basis")
+    (synopsis "Word difference finder")
     (description
      "GNU Wdiff is a front end to 'diff' for comparing files on a word per
 word basis.  A word is anything between whitespace.  This is useful for
@@ -58,4 +61,4 @@ paragraphs have been refilled.  It works by creating two temporary files, one
 word per line, and then executes 'diff' on these files.  It collects the
 'diff' output and uses it to produce a nicer display of word differences
 between the original files.")
-    (license gpl3+)))
\ No newline at end of file
+    (license gpl3+)))