summary refs log tree commit diff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-09 14:44:48 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-09 14:44:48 +0200
commitda3be3ff4f6d8b643ed9bdf6834df366b1bcea44 (patch)
tree913ff6010447b6a31dfbe4be6eccc06b11fd83cf /gnu/packages/web-browsers.scm
parentf5fe0082abe4547f3fb9f29d8351473cfb3a387b (diff)
parent4980630d1e3e6f9a6dc05438c7593a727207d9a0 (diff)
downloadguix-da3be3ff4f6d8b643ed9bdf6834df366b1bcea44.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm55
1 files changed, 29 insertions, 26 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index b272319b89..f30e654856 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -158,41 +158,44 @@ management, extensions such as advertisement blocker and colorful tabs.")
 (define-public links
   (package
     (name "links")
-    (version "2.25")
+    (version "2.26")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://links.twibright.com/download/"
                                   "links-" version ".tar.bz2"))
               (sha256
                (base32
-                "0b6x97xi8i4pag2scba02c0h95cm3sia58q99zppk0lfd448bmrd"))))
+                "1jy90k04kl7y3l8jzg5jx7fglyqzngng0964j7j67gjxy9vkanzh"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key outputs #:allow-other-keys)
-             ;; The tarball uses a very old version of autoconf. It doesn't
-             ;; understand extra flags like `--enable-fast-install', so
-             ;; we need to invoke it with just what it understands.
-             (let ((out (assoc-ref outputs "out")))
-               ;; 'configure' doesn't understand '--host'.
-               ,@(if (%current-target-system)
-                     `((setenv "CHOST" ,(%current-target-system)))
-                     '())
-               (setenv "CONFIG_SHELL" (which "bash"))
-               (invoke "./configure"
-                       (string-append "--prefix=" out)
-                       "--enable-graphics")))))))
+     (list
+       #:configure-flags #~(list "--enable-graphics")
+       #:phases
+       #~(modify-phases %standard-phases
+           (replace 'configure
+             (lambda* (#:key outputs (configure-flags '()) #:allow-other-keys)
+               ;; The tarball uses a very old version of autoconf. It doesn't
+               ;; understand extra flags like `--enable-fast-install', so
+               ;; we need to invoke it with just what it understands.
+               (let ((out (assoc-ref outputs "out")))
+                 ;; 'configure' doesn't understand '--host'.
+                 #$@(if (%current-target-system)
+                       #~((setenv "CHOST" #$(%current-target-system)))
+                       #~())
+                 (setenv "CONFIG_SHELL" (which "bash"))
+                 (apply invoke "./configure"
+                        (string-append "--prefix=" out)
+                        configure-flags)))))))
     (native-inputs (list pkg-config))
-    (inputs `(("gpm" ,gpm)
-              ("libevent" ,libevent)
-              ("libjpeg" ,libjpeg-turbo)
-              ("libpng" ,libpng)
-              ("libtiff" ,libtiff)
-              ("libxt" ,libxt)
-              ("openssl" ,openssl)
-              ("zlib" ,zlib)))
+    (inputs
+     (list gpm
+           libevent
+           libjpeg-turbo
+           libpng
+           libtiff
+           libxt
+           openssl
+           zlib))
     (synopsis "Text and graphics mode web browser")
     (description "Links is a graphics and text mode web browser, with many
 features including, tables, builtin image display, bookmarks, SSL and more.")