summary refs log tree commit diff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 22:39:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 13:31:34 +0200
commit2cab2eb675affded060bbe24e7fcbb4eee5db166 (patch)
tree86a53f15bb62d0001acb71d942695a50e143affe /gnu/packages/web-browsers.scm
parent43c110673263ec3ca66a7a44579a1608d7d053eb (diff)
downloadguix-2cab2eb675affded060bbe24e7fcbb4eee5db166.tar.gz
gnu: links: Update to 2.25.
* gnu/packages/web-browsers.scm (links): Update to 2.25.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 596d9f7f2b..8cd75e7a08 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -151,21 +151,21 @@ management, extensions such as advertisement blocker and colorful tabs.")
 (define-public links
   (package
     (name "links")
-    (version "2.23")
+    (version "2.25")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://links.twibright.com/download/"
                                   "links-" version ".tar.bz2"))
               (sha256
                (base32
-                "0idcwryfbf6ds5x2fx1k21m459qz5mrz3hw4a6ziiz91yl1d4q36"))))
+                "0b6x97xi8i4pag2scba02c0h95cm3sia58q99zppk0lfd448bmrd"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
-             ;; The tarball uses a very old version of autconf. It doesn't
+             ;; The tarball uses a very old version of autoconf. It doesn't
              ;; understand extra flags like `--enable-fast-install', so
              ;; we need to invoke it with just what it understands.
              (let ((out (assoc-ref outputs "out")))
@@ -176,8 +176,7 @@ management, extensions such as advertisement blocker and colorful tabs.")
                (setenv "CONFIG_SHELL" (which "bash"))
                (invoke "./configure"
                        (string-append "--prefix=" out)
-                       "--enable-graphics")
-               #t))))))
+                       "--enable-graphics")))))))
     (native-inputs `(("linux-libre-headers" ,linux-libre-headers)
                      ("pkg-config" ,pkg-config)))
     (inputs `(("gpm" ,gpm)