summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-12-04 01:00:52 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-12-11 01:00:00 +0100
commit8fe6d3e8446944294856950ef192cac83e03e58b (patch)
tree9f19f2d8e7e8ea7f1a6f6d432961e8197cd45955 /gnu/packages/web.scm
parentb5f3a1b84e2bd3e03452c57ef2785a8f98124361 (diff)
downloadguix-8fe6d3e8446944294856950ef192cac83e03e58b.tar.gz
gnu: yajl: Drop custom ‘lib-’ prefix.
* gnu/packages/web.scm (yajl): New variable, renamed from…
(libyajl): …this one, which is now a DEPRECATED-PACKAGE alias of yajl.
Adjust all users.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index c1e9e943c0..efb0313f05 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1395,9 +1395,9 @@ current version of any major web browser.")
 style API.")
     (license license:expat)))
 
-(define-public libyajl
+(define-public yajl
   (package
-    (name "libyajl")
+    (name "yajl")
     (version "2.1.0")
     (source (origin
               (method git-fetch)
@@ -1424,6 +1424,9 @@ style API.")
 parser written in ANSI C and a small validating JSON generator.")
     (license license:isc)))
 
+(define-public libyajl
+  (deprecated-package "libyajl" yajl))
+
 (define-public libwebsockets
   (package
     (name "libwebsockets")