summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-09 19:20:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-09 19:21:05 +0200
commit8325e1f8c4ca8acff802d98887fbc1a6b467ae4c (patch)
tree1784e76eefe3507a0435ddf3c599718588c1a1f5 /gnu/packages/web.scm
parente65bbec98fd32e4c7f71d3552b1a3be013f2be69 (diff)
downloadguix-8325e1f8c4ca8acff802d98887fbc1a6b467ae4c.tar.gz
gnu: fcgiwrap: Fix build with newer GCCs.
* gnu/packages/web.scm (fcgiwrap)[arguments]: Add ‘fix-CFLAGS’ phase.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6e89c3a406..7b0bb915ca 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -439,7 +439,15 @@ APIs.")
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no tests included
-       #:make-flags (list "CC=gcc")))
+       #:make-flags (list "CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-CFLAGS
+           ;; Remove broken options unconditionally added to CFLAGS.
+           (lambda _
+             (substitute* "configure.ac"
+               ((" -Werror") ""))
+             #t)))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)