summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-13 21:57:35 +0200
committerMarius Bakke <marius@gnu.org>2022-07-16 23:25:18 +0200
commit445658bbe134eea0eb39d5ee6d93f1608a4f6345 (patch)
tree4a97efc0a653224074e43b5305e7a5fcc8c76493 /gnu/packages/web.scm
parent5708638a9340ebd6a379f2d9f765e23371956b18 (diff)
downloadguix-445658bbe134eea0eb39d5ee6d93f1608a4f6345.tar.gz
gnu: node: Build with nghttp2@1.44.0.
* gnu/packages/web.scm (nghttp2-for-node): New variable.
* gnu/packages/node.scm (node, node-lts)[native-inputs, inputs]: Change from
NGHTTP2 to NGHTTP2-FOR-NODE.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8fef63a896..2397c8b64f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7568,6 +7568,22 @@ compressed JSON header blocks.
 @end itemize\n")
     (license license:expat)))
 
+;; Older variant for Node versions < 17 (upstream commit 43291b98edaa682
+;; add support for newer nghttp2, but is difficult to backport).
+(define-public nghttp2-for-node
+  (hidden-package
+   (package
+     (inherit nghttp2)
+     (version "1.44.0")
+     (source (origin
+               (method url-fetch)
+               (uri (string-append "https://github.com/nghttp2/nghttp2/"
+                                   "releases/download/v" version "/"
+                                   "nghttp2-" version ".tar.xz"))
+               (sha256
+                (base32
+                 "0p9wvva4g8hwj55x19rbyvnq2dbsnf65rphhxnpqs7ll54xlg6an")))))))
+
 (define-public hpcguix-web
   (package
     (name "hpcguix-web")