summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-27 23:54:23 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-27 23:54:23 +0100
commit2a8d44015ff2672b7a9a2ea5054b51a83b0e934b (patch)
tree00cdf5dac6acd2bd736a726bc5e032f328d29d6a /gnu/packages/web.scm
parentcc9a5c1454f49850c078045c88a300c1195eabc8 (diff)
downloadguix-2a8d44015ff2672b7a9a2ea5054b51a83b0e934b.tar.gz
gnu: libxml2: Add search path specification.
* gnu/packages/xml.scm (libxml2)[native-search-paths, search-paths]: New
  fields.
* gnu/packages/gnome.scm (gnome-doc-utils)[arguments]: Remove.
* gnu/packages/gps.scm (gpscorrelate)[arguments]: Remove settings for
  'XML_CATALOG_FILES' from 'configure' phase.
* gnu/packages/web.scm (tinyproxy)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1ff3dfb5a5..8a64211697 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -644,16 +644,7 @@ help you implement simple HTTP servers.")
           ;; Uncommenting the next two lines may assist in debugging
           ;; (substitute* "docs/man5/Makefile" (("a2x") "a2x -v"))
           ;; (setenv "XML_DEBUG_CATALOG" "1")
-
-          (setenv "XML_CATALOG_FILES" 
-                  (string-append
-                   (assoc-ref inputs "docbook-xsl") 
-                   "/xml/xsl/docbook-xsl-1.78.1/catalog.xml"
-                   ;; Contrary to the documentation, the file names must
-                   ;; be separated by a space, not a colon.
-                   " " 
-                   (assoc-ref inputs "docbook-xml") 
-                   "/xml/dtd/docbook/catalog.xml")))
+          #t)
         %standard-phases)))
     ;; All of the below are used to generate the documentation
     ;; (Should they be propagated inputs of asciidoc ??)