summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-09-04 21:00:10 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-09-05 00:21:43 +0200
commit9bf589867b57954e1245b2d1c937f1ae386a78ce (patch)
tree13a6fa3a66e30a83ffb62413fad418e8cc778d96 /gnu/packages/web.scm
parentfbcbafdcaa212695cd8548662260fd8b882cf0b3 (diff)
downloadguix-9bf589867b57954e1245b2d1c937f1ae386a78ce.tar.gz
gnu: nginx: Update to 1.17.3 [security fixes].
This release fixes CVE-2019-9511, CVE-2019-9513, and CVE-2019-9516.

* gnu/packages/web.scm (nginx): Update to 1.17.3.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 41e0035ce5..bea9f3dcc7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -208,14 +208,14 @@ Interface} specification.")
     ;; ’stable’ and recommends that “in general you deploy the NGINX mainline
     ;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
     ;; Consider updating the nginx-documentation package together with this one.
-    (version "1.17.2")
+    (version "1.17.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://nginx.org/download/nginx-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1v39gslwbvpfhqqv74q0lkfrhrwsp59xc8pwhvxns7af8s3kccsy"))))
+                "0g0g9prwjy0rnv6n5smny5yl5dhnmflqdr3hwgyj5jpr5hfgx11v"))))
     (build-system gnu-build-system)
     (inputs `(("openssl" ,openssl)
               ("pcre" ,pcre)