summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-04-27 22:47:17 -0400
committerLeo Famulari <leo@famulari.name>2023-04-30 04:47:19 -0400
commit3b3c7ef1f74d15471da482ca9b3720020c9f85f1 (patch)
tree8789494e5d9271fa4eb8761ce62421a36ca826cf /gnu/packages/web.scm
parentbdbf3e36cfed2a6e373bc32868264d85ec4932ac (diff)
downloadguix-3b3c7ef1f74d15471da482ca9b3720020c9f85f1.tar.gz
gnu: mod-wsgi: Make sure not to keep a store reference to HTTPD.
* gnu/packages/web.scm (mod-wsgi)[inputs]: Move httpd ...
[native-inputs]: ... to here.
[arguments]: Forbid keeping a reference to httpd.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8d5d94ced0..2f27d16440 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -335,14 +335,16 @@ and its related documentation.")
                 "1savh6h3qds20mwn1nqasmqzcp57pdhfc9v4b4k78d6q28y0r17s"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f                 ; TODO: can't figure out if there are tests
+     `(#:disallowed-references (,httpd)
+       #:tests? #f                 ; TODO: can't figure out if there are tests
        #:make-flags (list
                      (string-append "DESTDIR="
                                     (assoc-ref %outputs "out"))
                      "LIBEXECDIR=/modules")))
+    (native-inputs
+     `(("httpd" ,httpd)))
     (inputs
-     `(("httpd" ,httpd)
-       ("python" ,python-wrapper)))
+     `(("python" ,python-wrapper)))
     (synopsis "Apache HTTPD module for Python WSGI applications")
     (description
      "The mod_wsgi module for the Apache HTTPD Server adds support for running