summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-04 17:26:57 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-04 18:34:29 +0200
commit8e87aa04979dae66a1e45b54c0f92da07745e1e6 (patch)
treec3fdd0aab0c5d3a0c154d6ad34d6ed17dbbcc968 /gnu/packages/web.scm
parent38a9bf805d7ea476dce2a271bd93c36afb6ba3ae (diff)
downloadguix-8e87aa04979dae66a1e45b54c0f92da07745e1e6.tar.gz
gnu: hiawatha: Update to 10.8.3.
* gnu/packages/web.scm (hiawatha): Update to 10.8.3.
[source]: Also delete bundled copy of nghttp2.
[inputs]: Use mbedtls-for-hiawatha instead of vanilla mbedtls-apache.
* gnu/packages/tls.scm (mbedtls-for-hiawatha): New public variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8e776258b3..401711928d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5173,7 +5173,7 @@ functions of Tidy.")
 (define-public hiawatha
   (package
     (name "hiawatha")
-    (version "10.7")
+    (version "10.8.3")
     (source
      (origin
        (method url-fetch)
@@ -5181,15 +5181,16 @@ functions of Tidy.")
                            "hiawatha-" version ".tar.gz"))
        (modules '((guix build utils)))
        (snippet '(begin
-                   ;; We use our packaged mbedtls, so delete the included copy.
-                   (delete-file-recursively "mbedtls")
+                   ;; We use packaged libraries, so delete the bundled copies.
+                   (for-each delete-file-recursively
+                             (list "nghttp2" "mbedtls"))
                    #t))
        (sha256
         (base32
-         "0x2zfc8kc6c7rl4gwymwmg13w1c60biv6c6c9fvzpnl59bc9jgin"))))
+         "0w7047pwijhsbvvv1qjynp7gvn0nil56w82f7ax0gabrg7ddzk6s"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f ; No tests included
+     `(#:tests? #f                      ; no tests included
        #:configure-flags (list (string-append "-DUSE_SYSTEM_MBEDTLS=on")
                                (string-append "-DENABLE_TOMAHAWK=on")
                                (string-append "-DWEBROOT_DIR="
@@ -5212,8 +5213,8 @@ functions of Tidy.")
                (wrap-program (string-append sbin "/hiawatha")
                  `("PATH" ":" prefix (,mbed)))))))))
     (inputs
-     ;; TODO: package "hiawatha-monitor", an optional dependency of "hiawatha"
-     `(("mbedtls-apache" ,mbedtls-apache) ;Hiawatha includes this version.
+     ;; TODO: package "hiawatha-monitor", an optional dependency of "hiawatha".
+     `(("mbedtls-apache" ,mbedtls-for-hiawatha)
        ("zlib" ,zlib)
        ("libxslt" ,libxslt)
        ("libxml2" ,libxml2)))