summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-05-31 19:27:03 +0000
committerLudovic Courtès <ludo@gnu.org>2023-06-24 17:00:11 +0200
commitc46ea1826a82c9abf3e3352c3f7b40f8a96c2510 (patch)
treeb00d4b75e6575156e85e4cf0b0847a9bcfd3ecdc /gnu/packages/web.scm
parent73e7844c9c58e5d7c82d3334abdfceec5831bfe1 (diff)
downloadguix-c46ea1826a82c9abf3e3352c3f7b40f8a96c2510.tar.gz
gnu: Add yder.
* gnu/packages/web.scm (yder): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1df2d945a7..04e19a36a0 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -8831,6 +8831,43 @@ It is intended to provide low-level functionalities for the Ulfius and Yder
 libraries.")
     (license license:lgpl2.1)))
 
+(define-public yder
+  (package
+    (name "yder")
+    (version "1.4.19")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/babelouest/yder")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "02jgrqby39ykfdhc7z0bh3x5aqisqybz6lnvn7msh9wqbj5zvzi8"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:configure-flags #~(list "-DWITH_JOURNALD=OFF"
+                                     "-DBUILD_YDER_TESTING=ON"
+                                     "-DBUILD_YDER_DOCUMENTATION=ON")
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'build 'build-doc
+                          (lambda _
+                            (invoke "make" "doc")))
+                        (add-after 'install 'install-doc
+                          (lambda _
+                            (let ((doc (string-append #$output
+                                                      "/share/doc/yder")))
+                              (mkdir-p doc)
+                              (copy-recursively "../source/doc/html" doc)))))))
+    (native-inputs (list check doxygen subunit))
+    (inputs (list orcania))
+    (home-page "https://babelouest.github.io/yder/")
+    (synopsis "Logging library for C applications")
+    (description
+     "Yder is a logging library written in C.  It can log messages to the
+console, a file, syslog, journald, or a callback function.")
+    (license license:lgpl2.1)))
+
 
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances