summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-10-29 12:52:38 -0500
committerEric Bavier <bavier@member.fsf.org>2014-10-31 20:25:02 -0500
commit3484d052faac9d7dee316107a5976b1ffa228f73 (patch)
tree6ebd0cddce3676b3fe9ab416a061a869489239f4 /gnu/packages/web.scm
parenta16e9204adabc79275b458168f75a8dee3308dfc (diff)
downloadguix-3484d052faac9d7dee316107a5976b1ffa228f73.tar.gz
gnu: Add perl-io-socket-ssl.
* gnu/packages/web.scm (perl-io-socket-ssl): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1a426253dd..301e64b299 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -572,3 +572,26 @@ unavailable.")
 library.")
     (license (package-license perl))
     (home-page "http://search.cpan.org/~szbalint/WWW-Curl-4.17/lib/WWW/Curl.pm")))
+
+(define-public perl-io-socket-ssl
+  (package
+    (name "perl-io-socket-ssl")
+    (version "2.002")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/S/SU/SULLR/"
+                                  "IO-Socket-SSL-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1mph52lw6x5v44wf8mw00llzi8pp6k5c4jnrnrvlacrlfv260jb8"))))
+    (build-system perl-build-system)
+    (propagated-inputs `(("perl-net-ssleay" ,perl-net-ssleay)))
+    (synopsis "Nearly transparent SSL encapsulation for IO::Socket::INET")
+    (description
+     "IO::Socket::SSL makes using SSL/TLS much easier by wrapping the
+necessary functionality into the familiar IO::Socket interface and providing
+secure defaults whenever possible.  This way existing applications can be made
+SSL-aware without much effort, at least if you do blocking I/O and don't use
+select or poll.")
+    (license (package-license perl))
+    (home-page "https://github.com/noxxi/p5-io-socket-ssl")))