summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-10 01:26:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-12 20:49:13 +0100
commit6a4d56346cadfc5fab829a8e78fbbd5024729a11 (patch)
treed3124fbb5fd85c33d9a7aa90d85a25d6960c8d06 /gnu/packages/web.scm
parent62c75d6d089040daf18c891089e4ff367e924679 (diff)
downloadguix-6a4d56346cadfc5fab829a8e78fbbd5024729a11.tar.gz
gnu: nghttp2: Update to 1.35.1.
* gnu/packages/web.scm (nghttp2): Update to 1.35.1.
[native-inputs]: Add GCC-7.
[arguments]: Add workaround for <https://bugs.gnu.org/30756>.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index caf56e4119..17deb5c222 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -79,6 +79,7 @@
   #:use-module (gnu packages flex)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages kerberos)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages gd)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
@@ -6696,7 +6697,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
 (define-public nghttp2
   (package
     (name "nghttp2")
-    (version "1.32.0")
+    (version "1.35.1")
     (source
      (origin
        (method url-fetch)
@@ -6705,12 +6706,13 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
                            name "-" version ".tar.xz"))
        (sha256
         (base32
-         "0zbgp8f80h2zlfn8cd2ldrmgl81jzcdh1141n71aqmfckzaqj2kh"))))
+         "0fi6qg2w82636wixwkqy7bclpgxslmvg82r431hs8h6aqc4mnzwv"))))
     (build-system gnu-build-system)
     (outputs (list "out"
                    "lib"))              ; only libnghttp2
     (native-inputs
      `(("pkg-config" ,pkg-config)
+       ("gcc" ,gcc-7)                   ; 1.35.0 requires GCC6 or later
 
        ;; Required by tests.
        ("cunit" ,cunit)
@@ -6742,6 +6744,9 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
                (("@prefix@")
                 (assoc-ref outputs "lib")))
              #t))
+         (add-before 'configure 'work-around-bug-30756
+           (lambda _
+             (for-each unsetenv '("C_INCLUDE_PATH" "CPLUS_INCLUDE_PATH")) #t))
          (add-before 'check 'set-timezone-directory
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "TZDIR" (string-append (assoc-ref inputs "tzdata")