summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-30 17:07:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-12-03 17:06:51 +0100
commit9bad40435509470d71514ecab13dc585d0aa0296 (patch)
tree1bef7bd925c03565453e7a5906d6690ba186a9c1 /gnu/packages/web.scm
parentab519cfa3db289303eb2e640d959340b3f66e738 (diff)
downloadguix-9bad40435509470d71514ecab13dc585d0aa0296.tar.gz
gnu: Add fcgiwrap.
* gnu/packages/web.scm (fcgiwrap): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7c869c0b11..697bab8e56 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -226,6 +226,41 @@ APIs.")
     ;; the Expat license, incompatible with the GPL.
     (license (l:non-copyleft "file://LICENSE.TERMS"))))
 
+(define-public fcgiwrap
+  (package
+    (name "fcgiwrap")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/gnosek/fcgiwrap/"
+                           "archive/" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "07y6s4mm86cv7p1ljz94sxnqa89y9amn3vzwsnbq5hrl4vdy0zac"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no tests included
+       #:make-flags (list "CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'bootstrap
+           (lambda _
+             (zero? (system* "autoreconf" "-vif")))))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("fcgi" ,fcgi)))
+    (home-page "https://nginx.localdomain.pl/wiki/FcgiWrap")
+    (synopsis "Simple server for running CGI applications over FastCGI")
+    (description "Fcgiwrap is a simple server for running CGI applications
+over FastCGI.  It hopes to provide clean CGI support to Nginx (and other web
+servers that may need it).")
+    (license l:expat)))
+
 (define-public starman
   (package
     (name "starman")