summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-12-08 17:11:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-12-08 17:11:11 +0200
commite9acbe6d81d94d027331d457fc12ceb9b1b2a39e (patch)
treef56cab6bedbf73c700d22cb7cfa9bb4de7f7423f /gnu/packages/web.scm
parentdf4feb9e8b59dba373c29844b0dbb701266b4ffa (diff)
downloadguix-e9acbe6d81d94d027331d457fc12ceb9b1b2a39e.tar.gz
gnu: json-c: Absorb replacement with security fix.
* gnu/packages/web.scm (json-c)[source]: Add patch.
[replacement]: Remove.
(json-c/fixed): Remove.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ff40743832..163bfa22dc 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -894,7 +894,6 @@ data.")
 
 (define-public json-c
   (package
-    (replacement json-c/fixed)
     (name "json-c")
     (version "0.14")
     (source (origin
@@ -904,7 +903,8 @@ data.")
                    version ".tar.gz"))
              (sha256
               (base32
-               "0w381krr99q5a2rypx4g437fa7gzgl82i64sgnrs6g5jr44dwxxk"))))
+               "0w381krr99q5a2rypx4g437fa7gzgl82i64sgnrs6g5jr44dwxxk"))
+              (patches (search-patches "json-c-CVE-2020-12762.patch"))))
     (build-system cmake-build-system)
     (home-page "https://github.com/json-c/json-c/wiki")
     (synopsis "JSON implementation in C")
@@ -915,15 +915,6 @@ parse JSON-formatted strings back into the C representation of JSON objects.
 It aims to conform to RFC 7159.")
     (license license:x11)))
 
-(define json-c/fixed
-  (package
-    (inherit json-c)
-    (name "json-c")
-    (version "0.14")
-    (source (origin
-              (inherit (package-source json-c))
-              (patches (search-patches "json-c-CVE-2020-12762.patch"))))))
-
 ;; TODO: Remove these old versions when all dependents have been updated.
 (define-public json-c-0.13
   (package