summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-11 00:08:04 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-11 02:08:02 +0100
commitfd46742dd2191c7762590a15bc054bbfd1feb3fc (patch)
tree3c7b87ba3c11053d101fb901e6db2c4f08188165 /gnu/packages/web.scm
parent0330d6b2bfe98f5331b8761dc80083be80d3cf78 (diff)
downloadguix-fd46742dd2191c7762590a15bc054bbfd1feb3fc.tar.gz
gnu: nginx: Update to 1.15.9.
* gnu/packages/web.scm (nginx): Update to 1.15.9.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d9b7def67b..e6f339f7b7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -194,16 +194,18 @@ Interface} specification.")
 (define-public nginx
   (package
     (name "nginx")
-    ;; Consider updating the nginx-documentation package if the nginx package is
-    ;; updated.
-    (version "1.14.2")
+    ;; Track the ‘mainline’ branch.  Upstream considers it more reliable than
+    ;; ’stable’ and recommends that “in general you deploy the NGINX mainline
+    ;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
+    ;; Consider updating the nginx-documentation package together with this one.
+    (version "1.15.9")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://nginx.org/download/nginx-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "15wppq12qmq8acjs35xfj61czhf9cdc0drnl5mm8hcg3aihryb80"))))
+                "0hxfsz1117r91b9fb5hjddyrf1czvb36lh1z7zalqqdskfcbmkz4"))))
     (build-system gnu-build-system)
     (inputs `(("openssl" ,openssl)
               ("pcre" ,pcre)