summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2022-11-25 09:44:26 +0800
committerLudovic Courtès <ludo@gnu.org>2022-12-09 08:46:21 +0100
commit7fde9758c5a1d188354990e45df249cfd522a436 (patch)
tree30d1b8b06a066ea3e5b877af9ec108a21d01b25e /gnu/packages/web.scm
parente625e9b194f2de3ff20872f04b5c802c70cb411c (diff)
downloadguix-7fde9758c5a1d188354990e45df249cfd522a436.tar.gz
gnu: Add buku-run.
* gnu/packages/web.scm (buku-run): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8cde295841..c1e9e943c0 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -189,6 +189,7 @@
   #:use-module (gnu packages video)
   #:use-module (gnu packages vim)
   #:use-module (gnu packages wget)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xml)
   #:use-module ((srfi srfi-1) #:select (delete-duplicates)))
 
@@ -7764,6 +7765,46 @@ bookmarks directly.  It can also present them in a web interface with
 @command{bukuserver}.")
     (license license:gpl3+)))
 
+(define-public buku-run
+  (package
+    (name "buku-run")
+    (version "0.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/carnager/buku_run")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1zyjjf3b8g3dnymcrg683rbnc6qrvx8ravfm833n7kjrqky3bczn"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:tests? #f                  ;no tests
+           #:make-flags
+           #~(list (string-append "DESTDIR=" #$output)
+                   "PREFIX=")
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)
+               (add-after 'unpack 'fixpath
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   (substitute* "buku_run"
+                     ((" \\<(rofi)\\>" all cmd)
+                      (string-append " " (search-input-file inputs "/bin/rofi")))
+                     (("\\<(buku)\\> " all cmd)
+                      (string-append (search-input-file inputs "/bin/buku") " "))
+                     (("\\<(awk|gawk)\\>" cmd)
+                      (search-input-file inputs "/bin/awk"))
+                     (("/etc/buku_run.config" path)
+                      (string-append #$output path))))))))
+    (inputs (list buku rofi))
+    (home-page "https://github.com/carnager/buku_run")
+    (synopsis "rofi frontend for buku bookmarks manager")
+    (description
+     "This package provides a rofi frontend for the buku bookmark manager.")
+    (license license:gpl3+)))
+
 (define-public anonip
   (package
     (name "anonip")